Bug 684806 - [abrt] gnome-system-monitor-2.99.1-1.fc15: g_settings_schema_get_value: Process /usr/bin/gnome-system-monitor was killed by signal 6 (SIGABRT)
Summary: [abrt] gnome-system-monitor-2.99.1-1.fc15: g_settings_schema_get_value: Proce...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-system-monitor
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3c00db1c077193e7d931262ea4c...
: 688861 690696 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-14 14:49 UTC by Vít Ondruch
Modified: 2014-06-18 09:14 UTC (History)
5 users (show)

Fixed In Version: gnome-system-monitor-2.99.3-2.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-29 04:00:39 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (30.49 KB, text/plain)
2011-03-14 14:49 UTC, Vít Ondruch
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 635939 0 None None None Never
GNOME Bugzilla 645662 0 None None None Never

Description Vít Ondruch 2011-03-14 14:49:37 UTC
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 31224 bytes
cmdline: gnome-system-monitor
component: gnome-system-monitor
Attached file: coredump, 27971584 bytes
crash_function: g_settings_schema_get_value
executable: /usr/bin/gnome-system-monitor
kernel: 2.6.38-0.rc8.git0.1.fc15.x86_64
package: gnome-system-monitor-2.99.1-1.fc15
rating: 4
reason: Process /usr/bin/gnome-system-monitor was killed by signal 6 (SIGABRT)
release: Fedora release 15 (Lovelock)
time: 1300114156
uid: 500

How to reproduce
-----
1. On "Processes" tab, I have tried to display "All processes"
2.
3.

Comment 1 Vít Ondruch 2011-03-14 14:49:40 UTC
Created attachment 484206 [details]
File: backtrace

Comment 2 Paul W. Frields 2011-03-26 21:48:02 UTC
*** Bug 690696 has been marked as a duplicate of this bug. ***

Comment 3 Paul W. Frields 2011-03-26 21:48:16 UTC
*** Bug 688861 has been marked as a duplicate of this bug. ***

Comment 4 Paul W. Frields 2011-03-26 21:48:53 UTC
This bug is still occurring in gnome-system-monitor-2.99.3-1.fc15.

Comment 5 Paul W. Frields 2011-03-26 21:52:11 UTC
This problem only exhibits on my Intel Core i7 machine, and it seems at least one of the other duplicate bugs had similar hardware (i7).  Either the schema should present enough colors for expected cores (what about dual i7's or more?), or the monitor should provide some random assignments for > 4 cpus.

Comment 6 Fedora Update System 2011-03-26 23:30:08 UTC
gnome-system-monitor-2.99.3-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnome-system-monitor-2.99.3-2.fc15

Comment 7 Paul W. Frields 2011-03-26 23:46:53 UTC
Thanks for this update Matthias, I'll try it out and give some karma.

Comment 8 Fedora Update System 2011-03-27 02:52:47 UTC
Package gnome-system-monitor-2.99.3-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-system-monitor-2.99.3-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gnome-system-monitor-2.99.3-2.fc15
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2011-03-29 04:00:34 UTC
gnome-system-monitor-2.99.3-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.