Bug 68481 - Very slow mouse movement: Inland Optical Mouse 100 PS/2
Very slow mouse movement: Inland Optical Mouse 100 PS/2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-10 11:58 EDT by Eugene Kanter
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-30 08:24:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2002-07-10 11:58:35 EDT
Description of Problem:

During the installation (7.2, 7.3 and Limbo) and after the install the mouse
pointers moves very slowly compare to other PS/2 mice and this mouse in Windows
on the same box. Moreover, if mouse moves very slow X pointer does not move at
all. Under Windows any slowest mouse movement moves pointer properly.
Comment 1 Mike A. Harris 2002-07-12 18:16:44 EDT
The mouse acceleration algorithms in X for the most part suck.  Microsoft
has far far superior mouse acceleration and speed algorithms.  This bothers
me as well, and tends to be worse at higher resolutions.  It is not really
considered a bug however upstream, or at least not a high priority one.

I would very much like to rewrite the mouse acceleration in X to not suck,
but there always seems to be much higher priority tasks needing work.  ;o/

I'll leave this open as an RFE to make X not suck.  However your best bet
for now, is to experiment with xset and possibly the GNOME or KDE mouse
control panel settings to try to get something more useable going.  You
may also want to change some mouse settings in the X config file to increase
the resolution and/or sensitivity.  A few users have reported improved mouse
performance by changing settings in the X config file by using the XF86Config
manpage and the mouse manpage as guidelines.

Rewriting this code is a longer term thing, something that might possibly
be done upstream.  Nonetheless, I will track it.
Comment 2 Eugene Kanter 2002-09-19 10:17:32 EDT
Logitec Optical mouse seems to work fine with XFree 4.1 Have not tested with 
4.2 yet.
Comment 3 Mike A. Harris 2002-11-04 06:39:27 EST
Have you tried mucking with the resolution settings, and other mouse
settings in the X config?  "man -a mouse" for details of all settings.

Is this problem still occuring in 8.0?

It's possible the problem I describe isn't the same as your reported
problem.  The X mouse accel code does suck rocks though.
Comment 4 Eugene Kanter 2002-11-04 08:30:48 EST
Original mouse device is no longer available for testing, but Logitec Optical
mouse works fine in Red Hat 8.0.
Comment 5 Mike A. Harris 2002-12-30 08:24:59 EST
Yep, I just bought 2 Logitech optical mice and both work fine for me.  ;o)

Staples had a sale on, I couldn't resist.  ;o)

Closing as CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.