Bug 684908 - [abrt] krename-4.0.6-2.fc15: ref: Process /usr/bin/krename was killed by signal 11 (SIGSEGV)
Summary: [abrt] krename-4.0.6-2.fc15: ref: Process /usr/bin/krename was killed by sign...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: krename
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Radek Novacek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:71627c9dfc3168913f92411d2e4...
: 684504 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-14 18:47 UTC by Rex Dieter
Modified: 2016-12-01 00:29 UTC (History)
4 users (show)

Fixed In Version: krename-4.0.7-2.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-22 03:44:08 UTC


Attachments (Terms of Use)
File: backtrace (9.13 KB, text/plain)
2011-03-14 18:47 UTC, Rex Dieter
no flags Details

Description Rex Dieter 2011-03-14 18:47:43 UTC
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 9351 bytes
cmdline: krename
component: krename
Attached file: coredump, 2928640 bytes
crash_function: ref
executable: /usr/bin/krename
kernel: 2.6.38-0.rc8.git0.1.fc15.x86_64
package: krename-4.0.6-2.fc15
rating: 4
reason: Process /usr/bin/krename was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Lovelock)
How to reproduce: krename crash on startup
time: 1300128451
uid: 500

Comment 1 Rex Dieter 2011-03-14 18:47:45 UTC
Created attachment 484284 [details]
File: backtrace

Comment 2 Rex Dieter 2011-03-14 18:48:34 UTC
*** Bug 684504 has been marked as a duplicate of this bug. ***

Comment 3 Kevin Kofler 2011-03-14 22:24:45 UTC
As discussed on IRC, this is an issue with the order of static initializations in C++ not being defined, and the initializations now running in the wrong order.

The easiest fix is to change krename-4.0.6/src/plugin.cpp:22 from:
const QString Plugin::S_TOKEN_SEPARATOR = TokenHelpDialog::S_TOKEN_SEPARATOR;
to:
const QString Plugin::S_TOKEN_SEPARATOR = ";;";

Comment 4 Fedora Update System 2011-03-16 16:02:12 UTC
krename-4.0.7-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/krename-4.0.7-2.fc15

Comment 5 John Rosich 2011-03-16 16:25:53 UTC
krename-4.0.7-2 fixed the problem. Thanks to all.
John

Comment 6 Fedora Update System 2011-03-22 03:44:04 UTC
krename-4.0.7-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.