Bug 685005 - [abrt] udftools-1.0.0b3-12.fc14: next_extent_size: Process /usr/bin/mkudffs was killed by signal 11 (SIGSEGV)
[abrt] udftools-1.0.0b3-12.fc14: next_extent_size: Process /usr/bin/mkudffs w...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: udftools (Show other bugs)
14
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
abrt_hash:72d99030bfbb59067b758b24321...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-14 23:18 EDT by Jim Shipman
Modified: 2012-02-07 02:52 EST (History)
2 users (show)

See Also:
Fixed In Version: udftools-1.0.0b3-15.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 02:52:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (5.62 KB, text/plain)
2011-03-14 23:18 EDT, Jim Shipman
no flags Details
proposed patch (1.38 KB, patch)
2012-01-27 07:07 EST, Honza Horak
no flags Details | Diff

  None (edit)
Description Jim Shipman 2011-03-14 23:18:24 EDT
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 5760 bytes
cmdline: mkudffs --media-type=dvdram /dev/sr0
component: udftools
Attached file: coredump, 380928 bytes
crash_function: next_extent_size
executable: /usr/bin/mkudffs
kernel: 2.6.35.11-83.fc14.x86_64
package: udftools-1.0.0b3-12.fc14
rating: 4
reason: Process /usr/bin/mkudffs was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1300158914
uid: 500

How to reproduce
-----
1. I was using mkudffs --type=dvdram on a dvdram that I have trouble reading on a dvd recorder
2.
3.
Comment 1 Jim Shipman 2011-03-14 23:18:26 EDT
Created attachment 484345 [details]
File: backtrace
Comment 2 Honza Horak 2011-03-15 03:32:14 EDT
Thanks for reporting. Could you provide some more info about the crash, please?

Is this happening every-time or it happened just once? Do you have a clue what can be wrong with the DVD medium?

Is it possible to attach the coredump file too?
Comment 3 Honza Horak 2011-03-24 04:35:00 EDT
I've forwarded this failure to upstream (https://sourceforge.net/tracker/?func=detail&aid=3240009&group_id=295&atid=100295) and will get you know here, if there is any progress. 

Unfortunately, I can't reproduce the failure, so it is very difficult to determine, where the problem is. If this failure will repeat with other media, please, let me know in comments here.
Comment 4 Vitezslav Cizek 2012-01-25 11:31:08 EST
I've stumbled upon this bug too.

Looking at next_extent_size() in extent.c:
...
        while (start_ext != NULL && start_ext->blocks < blocks)
                start_ext = next_extent(start_ext->next, type);

        if (start_ext->start % offset) <-- NULL pointer dereference here
...

It's easy to reproduce for me:

> dd if=/dev/zero of=udf.iso bs=2048 count=100
100+0 records in
100+0 records out
204800 bytes (205 kB) copied, 0,000659985 s, 310 MB/s
> mkudffs udf.iso
[1]    12702 segmentation fault  mkudffs udf.iso
Comment 5 Honza Horak 2012-01-27 07:07:09 EST
Created attachment 557850 [details]
proposed patch

(In reply to comment #4)
> It's easy to reproduce for me:
> 
> > dd if=/dev/zero of=udf.iso bs=2048 count=100
> 100+0 records in
> 100+0 records out
> 204800 bytes (205 kB) copied, 0,000659985 s, 310 MB/s
> > mkudffs udf.iso
> [1]    12702 segmentation fault  mkudffs udf.iso

Thanks for the reproducer, the patch is attached and has been also forwarded to upstream. However, upstream is not very active, so I'm going to use the patch together with some other fixes soon.
Comment 6 Fedora Update System 2012-01-27 07:53:20 EST
udftools-1.0.0b3-15.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/udftools-1.0.0b3-15.fc16
Comment 7 Fedora Update System 2012-01-27 22:31:25 EST
Package udftools-1.0.0b3-15.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing udftools-1.0.0b3-15.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0992/udftools-1.0.0b3-15.fc16
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-02-07 02:52:03 EST
udftools-1.0.0b3-15.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.