Bug 68502 - X Doesn't Work on new Intel 845G Chipset Machines
X Doesn't Work on new Intel 845G Chipset Machines
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-07-10 14:54 EDT by C.M. Connelly
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-07-17 14:07:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg output (8.73 KB, text/plain)
2002-07-10 14:55 EDT, C.M. Connelly
no flags Details
lspci output (884 bytes, text/plain)
2002-07-10 14:56 EDT, C.M. Connelly
no flags Details
output of uname -a (82 bytes, text/plain)
2002-07-10 14:56 EDT, C.M. Connelly
no flags Details
XFree86.0.log (36.52 KB, text/plain)
2002-07-11 21:05 EDT, C.M. Connelly
no flags Details
XF86Config-4 (3.67 KB, text/plain)
2002-07-11 21:06 EDT, C.M. Connelly
no flags Details

  None (edit)
Description C.M. Connelly 2002-07-10 14:54:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
Dell Dimension 4500S machines use the new Intel 845G chipset, which includes
onboard ``Intel Extreme Graphics''.  Unfortunately, X doesn't work properly with
this chipset -- setup doesn't detect things properly, and using the workaround
suggested by Intel (use the vesa driver) at 
<http://support.intel.com/support/graphics/intel845g/linux.htm> results in X
starting once, at a low resolution only.  Logging in and logging out (or
stopping and restarting gdm by hand) results in X trying to come up but failing
to actually draw the display.

Version-Release number of selected component (if applicable): 4.2.0-8

How reproducible:

Steps to Reproduce:
1. Start the computer
2. Log in
3. Log out

Actual Results:  X never quite comes back, although it doesn't die, either -- it
just gives you a blank screen.

Expected Results:  X should have restarted and presented a gdm login panel.

Additional info:
Comment 1 C.M. Connelly 2002-07-10 14:55:33 EDT
Created attachment 64644 [details]
dmesg output
Comment 2 C.M. Connelly 2002-07-10 14:56:06 EDT
Created attachment 64645 [details]
lspci output
Comment 3 C.M. Connelly 2002-07-10 14:56:38 EDT
Created attachment 64646 [details]
output of uname -a
Comment 4 C.M. Connelly 2002-07-11 21:05:49 EDT
Created attachment 65026 [details]
Comment 5 C.M. Connelly 2002-07-11 21:06:20 EDT
Created attachment 65027 [details]
Comment 6 Mike A. Harris 2002-07-12 17:42:52 EDT
Intel i845 is not supported by XFree86 4.2.0.  This is not a bug, just
something that is not supported.  The CVS trunk has support for this chipset,
which I have backported into rawhide currently.  Since the specs are not
publically available for this chipset yet, and since I do not have the
hardware, this backport is totally unsupported, and provided only for
end user convenience in hopes that it will work.  Users who try rawhide
XFree86 and have problems getting i845 to work, are encouraged to report
any problems to the upstream developers who have written this support, in
hopes that they will fix any problems that arise.  Also, if I'm informed
of any fixes upstream for this chipset, I will try to integrate them into
future releases - again in an unofficial "hope it works now" manner, but
still not officially supported.

For reference, the XFree86 status page lists the hardware currently claimed
to be supported by XFree86:  http://www.xfree86.org/4.2.0/Status.html
Here is the Intel specific page:  http://www.xfree86.org/4.2.0/Status17.html#17

Hope this helps.
Comment 7 C.M. Connelly 2002-07-17 14:07:53 EDT
Intel claims that this chipset whould work with XFree86 using the VESA driver --
see <http://support.intel.com/support/graphics/intel845g/linux.htm>.

It doesn't.
Comment 8 Mike A. Harris 2002-07-18 01:49:13 EDT
Perhaps I was not quite clear above, when I said that the Intel i845 is not
supported.  Let me clarify that a bit.

The Intel i845 graphics chipset, is not supported.  That means that it is
not supported by XFree86, because there is no code in the native Intel
i810 driver to drive this hardware.  That also means that this chip is
not at all in any way supported by Red Hat.  Not supported, means it is
not a chip which we support, offer technical support for, fix bugs in,
etc. because it is unsupported.

For unsupported hardware, users may or may not be able to get the given
hardware to work with the "vesa" driver, the "vga" driver, or by using
the kernel framebuffer device support and the fbdev X driver support.
If any of these alternative drivers work, that is great because it allows
the user to still use their unsupported hardware in possibly slow and
possibly mediocre way, rather than have no way to use XFree86 at all.

However, if these "unsupported" methods do not work, then there is not
anything to do about it, because we simply do not support hardware which
is not supported by a native stable XFree86 device driver.

Regardless of Intels claims of the "vesa" driver working or not working,
this chip is still unsupported.  The "vesa" driver uses the cards BIOS
to implement 2D driver support, so if "vesa" does not work, it generally
points at a bug in the video card's BIOS code.  That is something only
resolveable by the BIOS vendor, and does not fall into the Red Hat
supported category either.

I hope that clarifies what is meant by "support".

Note You need to log in before you can comment on or make changes to this bug.