Bug 68522 - Unable to modify physical volumes used by a volume group
Unable to modify physical volumes used by a volume group
Status: CLOSED DEFERRED
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
: FutureFeature
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-10 17:03 EDT by Michal Jaegermann
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-18 13:27:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2002-07-10 17:03:14 EDT
Description of Problem:

Assume that on a partition creation/assignment screen a user created
an LVM volume and after hitting "OK" realized, say, that a mount point
is wrong (a typo, or a slip of a mouse on pre-canned choices, or ...).
A natural thing is to try to "Edit" what was done and then a user is confronted
with an alert which basically says "You cannot do that.  This is an LVM volume."
without any hints how to get unstuck.

Those brave/patient/inquisitive enough may find eventually that by editing
LVM volume they may remove partitions from it and then a damage can be
undone but a general reaction most likely will be a panic.  Some extra
sentence indicating what can be done instead of a bare "You cannot ..."
would likely go a long way to prevent that.
Comment 1 Michael Fulbright 2002-07-12 16:38:15 EDT
You're referring to editting a logical volume?

Could you give an exact sequence to generate this popup? Its not ringing a bell.
You can edit logical volumes and volume groups after they have been created so
I'm not sure what the issue is.
Comment 2 Michal Jaegermann 2002-07-12 18:56:06 EDT
No, apparently I cannot without redoing the whole installation from scratch
because on a "Disk Setup" screen attempts to edit one of constituent
partitions lead to "Unable To Edit" alert (where a hint to try to edit
a logical volume instead is missing - as noted in the original report) and
if you try to edit a logical volume instead then what can be done seems
to be now very limited in scope.  In any case attempts to take out
physical partitions out of logical volume are completely and silently ignored
(which looks like the next bug).

Try something like that
  - take one or more of unused partitions and make them into a logical volume
  - tell in a dialog that it will be mounted on /udr, say
  - click OK
  - say "oops"
  - and try to do what somebody using Red Hat distributions from some time,
    but not too familiar with LVM, would naturally have done to make this
    mountable on /usr instead
  - you will get "Unable To Edit" alert without any indications what
    else you should have done
Comment 3 Michael Fulbright 2002-07-24 12:37:02 EDT
If I understand correctly, you are saying if you create partitions of type
'physical volume (LVM)', then put it in a Volume Group using the 'LVM' button,
and then add a logical volume to the volume group, if you then go and try to
modify the physical volume that started all this you are not allowed to.

This is true for this release - we are going to work on this screen more in
future release.  At the moment bad things can happen if you make radical changes
to a physical volume that is part of a volume group (like the volume group is
all of a sudden too small to hold all the logical volumes in it), and will
require alot more sanity checking when changes are made. Marking this as DEFERRED.


Note You need to log in before you can comment on or make changes to this bug.