Bug 68526 - Rhnpush not working
Rhnpush not working
Status: CLOSED RAWHIDE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Greg DeKoenigsberg
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-10 18:11 EDT by Matt Jamison
Modified: 2007-07-31 15:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-19 10:30:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Komenda 2002-07-10 18:11:12 EDT
Description of Problem: running rhnpush on sat 1.1 results in a traceback: 

[root@sat-inst rhn]# rhnpush -v --server=http://sat-inst.test.redhat.com/APP
-u jkomenda -c channel1 /etc/sysconfig/rhn/rhns-ca-cert-1.0-1.*
Channels: channel1
Red Hat Network password:
Connecting to http://sat-inst.test.redhat.com/APP
Uploading package /etc/sysconfig/rhn/rhns-ca-cert-1.0-1.noarch.rpm

Error Message:
    Package upload failed: [Errno 13] Permission denied: '/var/satellite/rhn'
Error Class Code: 50
Error Class Info: Invalid information uploaded to the server
Explanation:
     An error has occurred while processing your request. If this problem
     persists please submit a bug report to rhn-help@redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
Comment 1 Mihai Ibanescu 2002-07-10 18:32:12 EDT
Fixed in CVS.
Comment 2 Josef Komenda 2002-07-11 15:11:55 EDT
Not fixed: 

[root@sat-inst root]# rhnpush -v --server=http://sat-inst.test.redhat.com/APP
-u jkomenda -c channel1 /etc/sysconfig/rhn/rhns-ca-cert-1.0-1.*
Channels: channel1
Red Hat Network password:
Connecting to http://sat-inst.test.redhat.com/APP
Uploading package /etc/sysconfig/rhn/rhns-ca-cert-1.0-1.noarch.rpm

Error Message:
    Package upload failed: [Errno 13] Permission denied: '/var/satellite'
Error Class Code: 50
Error Class Info: Invalid information uploaded to the server
Explanation:
     An error has occurred while processing your request. If this problem
     persists please submit a bug report to rhn-help@redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
Comment 3 Josef Komenda 2002-07-11 15:27:43 EDT
This works when you create the directory specified in the Installer, then chown
it to apache:

mkdir /var/satellite
chown apache.apache /var/satellite

Over to Adrian to have the installer handle this.
Comment 4 Josef Komenda 2002-07-11 15:34:12 EDT
Correction - over to Greg to update the docs - this is best handled post-install.
Comment 5 Josef Komenda 2002-07-11 15:37:36 EDT
The correct dir to create would be /var/satellite/redhat
Comment 6 Todd Warner 2002-07-12 10:44:28 EDT
Due to the chicken-n-egg problem of mountpoints not existing during the
install process, the installer cannot create the directory and then chown it.
Therefore the documentation _must_ describe what to do.

However, if satellite-{sync,import} is to be used prior to ever using
rhnpush, no manual intervention is needed. Either tool will create and
properly set the permissions of that directory.

By the way, I vote to change the default mountpoint to
/var/spool/rhn-satellite.
Comment 7 Josef Komenda 2002-07-16 15:43:56 EDT
Docs should read like so: 
 - mkdir /var/satellite
 - chown apache.apache /var/satellite
Comment 8 Greg DeKoenigsberg 2002-07-19 10:30:36 EDT
Will close this in the docs by requiring a channel to be imported or synched
before a custom channel may be created.

Note You need to log in before you can comment on or make changes to this bug.