Bug 68535 - libglade needs to depend on gnome-libs with libdb.so.2
libglade needs to depend on gnome-libs with libdb.so.2
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: libglade (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-07-10 20:19 EDT by Jonathan Kamens
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-03 15:02:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-07-10 20:19:12 EDT
One of the libraries in the libglade package, libglade-gnome, is linked against
libdb.so.2, which is provided by recent versions of gnome-libs.  However, a very
old and incompatible version of libdb.so.2 is provided by libc-5.3.12-31, which
I have installed on my machine.  I then tried to compile an application which
uses the libglade-gnome library, and it tried to use the old version of
libdb.so.2 (since I didn't have a recent enough gnome-libs) and failed.

The gnome-libs dependency in the libglade package needs to indicate a version of
gnome-libs that is recent enough that it provides libdb.so.2.

A related issue here is that libdb.so.2 does not show up when you run "rpm -q
--requires libglade".  I don't understand why.
Comment 1 Owen Taylor 2003-01-03 15:02:18 EST
Not _exactly_ sure what the right resolution here is, but I'm inclined
to say nothing. The libglade package doesn't require the newer version
of gnome-libs, it requires the version it specifies and libdb.so.2.
(With the dependency on libdb.so.2 being only because it uses gnome-libs)

We shipped libdb.so.2 in a separate package for years; it got moved
into gnome-libs for 8.0, since nothing else used it. If you install 
another package on the system that provides this library, all sorts 
of things are going to go wrong.

There are all sorts of ways one could break a system by installing a 
package that provides a spurious incorrect library version; don't think
there is anything special about this one.


Note You need to log in before you can comment on or make changes to this bug.