Bug 68543 - anaconda installer thinks partition table is corrupt (debian works fine)
anaconda installer thinks partition table is corrupt (debian works fine)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
All Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-10 21:35 EDT by jerry asher
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump (snake poop?) (37.23 KB, text/plain)
2002-07-10 21:36 EDT, jerry asher
no flags Details
My anaconda bug dump (35.58 KB, text/plain)
2002-07-25 03:10 EDT, Ralph Baddour
no flags Details
fdisk partition table prints and dumps (22.85 KB, text/plain)
2002-08-18 18:49 EDT, George Foot
no flags Details

  None (edit)
Description jerry asher 2002-07-10 21:35:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530

Description of problem:
I have an HP Pavilion ze5000s laptop.  I cannot get Red Hat 7.3 to get
past the disk partition/formatting.  There is at least one anaconda
bug (I've attached the crash dump.)

I CAN GET DEBIAN 2.2R6 TO INSTALL TO IT, BUT I NEED RED HAT ON IT.
(Mandrake 8.2 will not install either.)

2Ghz, P IV, 30Mb HD, 512Mb RAM,
Windows XP Home.  Synaptics touch-pad, CD-ROM and floppy.

CPU: Intel Mobile Pentium 4 processor-M.
Core logic: ALI 1671 / 1535+ chipset.
Display controller: ATI Mobility Radeon M6-C/P.
Audio/Modem controller: Conexant Smart AMC CX20468-21.
CardBus controller: TI PC1520.
Keyboard/embedded controller: National PC87570.
Super I/O: integrated in core logic.
IEEE 1394: TI TSB43AB22.
LAN: National NS83815.
802.11b wireless LAN: Ambit with Intersil Prism 2.5 chipset.

It comes with a 30G disk, and with two partitions, a 24Mb "SaveToDisk"
partition, and then a 30Gb Windows XP (NTFS)

(I have recovered this many times with the HP recovery CDs).  To
install Linux, I use Partition Magic to shrink the Windows XP
partition from 30Mb to 10Mb.

For the most part, whenever the installer tries to access the
partition table, it takes a very very long time.  As in minutes.
Sometimes, but not always, it will complain that the partition table
is unreadable or corrupt, and asked if I wish to initialize the disk.
I don't.  I don't plan on using Windows XP much, but I will need it at
times.

Also, neither PartitionMagic, Norton Disk Doctor, nor Windows believes
the partition table is bad.

I have tried repartitioning/formatting with fdisk, with disk druid,
and with Partition Magic.  Nothing works for Red Hat.

Again, Debian has no problems installing.  (And again, I have several
times wiped the disk and used the recovery CDs to try a fresh
install.)

The filesystems are usually /boot, swap, and /.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. fly out to berkeley
2. come visit me
3. let me buy you coffee
4. reformat laptop with hp recovery disks
5. shrink partition
6. install red hat.
	

Actual Results:  anaconda dies often, sometimes it merely complains it cannot
read the partition table and then it kills the install process.

Expected Results:  anaconda should have created a new partition table.

Additional info:
Comment 1 jerry asher 2002-07-10 21:36:16 EDT
Created attachment 64705 [details]
anaconda dump (snake poop?)
Comment 2 jerry asher 2002-07-10 22:33:08 EDT
I booted with the debian install cd and used their installer to partition the
drive and format /, /boot and swap.  Debian is using cfdisk.
Comment 3 Michael Fulbright 2002-07-23 12:58:50 EDT
The error log shows alot of error messages showing read errors from /dev/hda.

This is most likely either due to a bad disk or a kernel driver issue.
Comment 4 Ralph Baddour 2002-07-25 03:09:40 EDT
Similar type of issues on my HP Omnibook 900b (PIII 450MHz, 192 MB RAM, 30 GB 
IBM HD). Currently have 2 partitions: a Phoenix BIOS hibernate (save-to-disk) 
partition and a partition for Win'98. There is about 3 GB left free at the end 
of the disk which I wanted to use to install Redhat 7.3. When the installation 
utility (anaconda) gets to the automatic partitioning it warns me that there is 
some "inconsistencies" with the partition table, but it says it is OK to 
ignore. I ignore. Next screen is to pick where to review where it has selected 
to install; clicking Next here results in a crash. Anaconda dump will be 
attached.
Comment 5 Ralph Baddour 2002-07-25 03:10:37 EDT
Created attachment 66985 [details]
My anaconda bug dump
Comment 6 George Foot 2002-08-18 18:43:28 EDT
I have a problem which may be related.  I have a dual boot of Windows 98 and a
mix-and-match Linux based on Redhat 6.0, and am trying to install 7.3 alongside,
before copying across my user files etc and deleting the older version.  The
install program successfully reads the iso images from one of my partitions, but
just before the partitioning stage, after I choose fdisk, anaconda gives the
corrupt partition table error, offering to wipe it; I say no and it aborts the
installation.

What exactly is involved in this partition table check?  Can I bypass it?  I'm
doing manual partitioning anyway; I even tried creating the partitions in
advance, ready for it to install into.  My old Linux still runs fine, and fdisk
has no complaints (other than the usual warning about >1024 cylinders).  Using
the root shell (on Alt-F2 I think) the newer fdisk did mention that my
partitions were not in disk order, but it happily fixed that.  I did originally
have partitions numbered up to /dev/hda17, but I had to reduce that anyway since
the installer can't read the isos from such high-numbered partitions.

I'll attach a dump of my partition table.
Comment 7 George Foot 2002-08-18 18:49:59 EDT
Created attachment 71384 [details]
fdisk partition table prints and dumps
Comment 8 Giorgio Weston 2002-09-22 04:30:53 EDT
Same problem here with RH 7.3 on HP Omnibook vt6200.
Comment 9 jerry asher 2002-09-22 04:44:47 EDT
I eventually returned that HP for a Dell Inspiron 8200 (Dude!).  And that 8200
just sucked up Linux.  Trivial install for the most part.

But shortly after I did that, I was told via email that there are some kernel
switches you can pass in at boot time that should get the partition formatted
and Red Hat booted.  I am away from my email repository right now or I would
look for the message.  But if you have a RH support contract, you should be able
to get RH to look into this for you.
Comment 10 Giorgio Weston 2002-09-25 07:13:00 EDT
Hi all,
	I found something that solves the problem (for me at least).

The problem seems to be related to the ALI chipset (ALI15X3) and its driver.
The clock speed is incorrectly detected at 33MHz, which causes the devices not
to work properly.

Adding idebus=50 as a parameter to the linux kernel seems to solve the problem.
RH 7.3 is now happily installing.

This is the linux.kernel thread discussing the issue, and where I found the
solution. 
http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&threadm=20020327233812.GA7310%40galileo&rnum=7&prev=/groups%3Fq%3Dlinux%2BALI15X3%26hl%3Den%26lr%3D%26ie%3DUTF-8%26selm%3D20020327233812.GA7310%2540galileo%26rnum%3D7
Comment 11 Bugzilla owner 2004-09-30 11:39:45 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.