Bug 68545 - Would like to see an /etc/init.d script for fetchmail
Would like to see an /etc/init.d script for fetchmail
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: fetchmail (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-10 22:14 EDT by Martin Jackson
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-21 16:35:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Jackson 2002-07-10 22:14:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.0.0) Gecko/20020530

Description of problem:
I run fetchmail on my home server in daemon mode.  It helps a lot to have a
chkconfig-aware /etc/init.d script to stop/start it. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
N/A

Actual Results:  N/A

Expected Results:  N/A

Additional info:

Mandrake comes with a chkconfig script for fetchmail that happens to work under
Red Hat.  I also like their idea of installing it as a separate package
(fetchmail-daemon, they call it).
Comment 1 Warren Togami 2002-07-12 08:12:39 EDT
I second the motion for fetchmail in /etc/init.d.  Secondary package not
necessary though, because wouldn't that be really tiny?  K.I.S.S.
Comment 2 Nigel Smith 2002-07-16 18:01:50 EDT
Yes, I also think that adding a service script for fetchmail is a good idea.
Comment 3 Miloslav Trmač 2005-06-21 16:35:58 EDT
I'm sorry about the late response.

Given the intrinsic reliability problems with running fetchmail unattended
(if a bounce message can't be sent, the mail is lost without a trace) and the
expected limited usage of fetchmail in such a scenario, I don't think adding
this feature is worth it, with all the set up necessary to run fetchmail under
a non-root user.

A different way to get equivalent functionality is to create a local
"fetchmail" user and add 
  fetchmail -d $timeout 2>&1 |grep -v 'while a background fetchmail is running'
to crontab of the "fetchmail" user.

Note You need to log in before you can comment on or make changes to this bug.