Bug 68561 - CD- and DVD-burners should be configured as ide-scsi
CD- and DVD-burners should be configured as ide-scsi
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-07-11 03:51 EDT by H. Peter Anvin
Modified: 2014-03-16 22:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-30 01:02:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H. Peter Anvin 2002-07-11 03:51:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020524

Description of problem:
CD- and DVD-burners require the use of the ide-scsi driver.  Unfortunately, the
ide-scsi module and ide-cdrom driver are mutually exclusive for any one device.
 Therefore, the installer/kudzu, or perhaps the kernel, should:

a) Detect CD-ROM like devices with write capability;
b) Force use of the ide-scsi driver for those device;
c) Set up the appropriate links as /dev/cdrom -> sr0 instead of -> hdc, etc.

One possible way of doing this would be to completely deprecate use of both the
ide-cdrom and ide-tape devices, and use ide-scsi for *all* IDE tape- and CD-ROM
devices.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Try to use a CD-burner in a newly installed system.  (cdrecord -scanbus should
detect the device.  If not, it's broken.)

Additional info:
Comment 1 Bill Nottingham 2002-07-11 23:49:33 EDT
The installer sets up some of this stuff. I don't know that we'd want to go to
ide-scsi for *all* CDs and tapes. Maybe if the other drivers were removed from
the kernel and it always worked this way without configuration. :)
Comment 2 Taco Witte 2002-08-08 18:09:35 EDT
In my experience, this is set-up perfectly in Limbo2. CDrecord works directly,
and mounting works afterwards.
Still problems in Limbo2 with configuration of cd-burner?
Comment 3 Taco Witte 2002-08-21 09:33:02 EDT
This bug is solved long ago, I believe.

I didn't find this problem in Limbo2 or (null), running cdrecord -scanbus as
root always works, and mounting afterwards works as well.

Note You need to log in before you can comment on or make changes to this bug.