Bug 68568 - Probing video card makes video card list unreadable
Probing video card makes video card list unreadable
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: gtk2 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-11 05:54 EDT by Mattias Dahlberg
Modified: 2007-04-18 12:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-12 14:20:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of virgin situation (138.81 KB, image/png)
2002-08-03 19:24 EDT, Peter van Egdom
no flags Details
This is how a virgin looks when probed 15 times (139.51 KB, image/png)
2002-08-03 19:26 EDT, Peter van Egdom
no flags Details
... And after 40 times pressing 'the probe button' (133.71 KB, image/png)
2002-08-03 19:28 EDT, Peter van Egdom
no flags Details
Clicked probe 70 times ( +/- 5 ) (127.39 KB, image/png)
2002-08-03 19:29 EDT, Peter van Egdom
no flags Details

  None (edit)
Description Mattias Dahlberg 2002-07-11 05:54:24 EDT
Description of problem:
When I probe my video card (btw it says "videocard" on that button, but "video 
card" everywhere else) it seems like the list of video cards get aligned to the 
right, which makes the entries unreadable. You can work around it by resizing 
the window to make it larger and then go back to the original size, then the 
list is left aligned again.


How reproducible:
Always

Steps to Reproduce:
1. Start redhat-config-xfree86
2. Go to Configure Video card
3. Click "Probe Videocard".
Comment 1 Alexander Larsson 2002-07-11 09:31:08 EDT
jrb: This was a TreeView bug, right?
Comment 2 Jonathan Blandford 2002-07-11 09:58:50 EDT
possible.  What are you doing to focus it?
Comment 3 Alexander Larsson 2002-07-11 10:05:59 EDT
   tree_view = self.xml.get_widget("videocard_tree")
   selection = tree_view.get_selection()
   selection.select_iter(iter)
   path = self.videocard_store.get_path(iter)
   tree_view.set_cursor(path, self.vc_col, FALSE)
   tree_view.scroll_to_cell(path, self.vc_col, TRUE, 0.5, 0.5)

I think it is the scroll_to_cell that breaks it.
I know we talked about this before.
Comment 4 Jonathan Blandford 2002-07-11 12:06:58 EDT
why are you center aligning it?
why not just do:
tree_view.scroll_to_cell(path, self.vc_col, TRUE, 0.5, 0.0)
or possibly,
tree_view.scroll_to_cell(path, None, TRUE, 0.5, 0.0)
Comment 5 Jonathan Blandford 2002-07-11 12:07:58 EDT
oh, you also prolly want to do a tree_view.grab_focus() afterwards to grab the
keyboard focus
Comment 6 Alexander Larsson 2002-07-23 10:07:26 EDT
Fixed in 0.5.1.
Comment 7 Peter van Egdom 2002-08-03 19:23:33 EDT
When I press 'probe videocard', the lists of videocards 'shifts to the left'.

I'll attach some attachments for this bugreport, showing the problem.

 00_before_clicking_probe.png
 01_clicking_probe_15_times.png
 02_clicking_probe_40_times.png
 03_clicking_probe_70_times.png

(the filenames speak for themselves)

Somehow I don't think this problem is fixed in version
"redhat-config-xfree86 0.5.1" :-)

[peterve@limbo-pc peterve]$ rpm -qa |grep -i xfree |grep conf
redhat-config-xfree86-0.5.1-1
[peterve@limbo-pc peterve]$

I looked in RAWHIDE for a newer version but found the same I'm using.

I suggest reopening this bug.
Comment 8 Peter van Egdom 2002-08-03 19:24:47 EDT
Created attachment 68784 [details]
Screenshot of virgin situation
Comment 9 Peter van Egdom 2002-08-03 19:26:41 EDT
Created attachment 68785 [details]
This is how a virgin looks when probed 15 times
Comment 10 Peter van Egdom 2002-08-03 19:28:26 EDT
Created attachment 68786 [details]
... And after 40 times pressing 'the probe button'
Comment 11 Peter van Egdom 2002-08-03 19:29:55 EDT
Created attachment 68787 [details]
Clicked probe 70 times ( +/- 5 )
Comment 12 Alexander Larsson 2002-08-07 08:36:19 EDT
Yeah. that looks bad.
Comment 13 Alexander Larsson 2002-08-09 05:49:52 EDT
jrb. This looks like a treeview bug. If i change the col_align to e.g. 0.1 it
scrolls like 10 pixels more on every time i do:
 tree_view.set_cursor(path, self.vc_col, FALSE)
 tree_view.scroll_to_cell(path, self.vc_col, TRUE, 0.5, 0.1)
Comment 14 Alexander Larsson 2002-08-09 05:55:16 EDT
For the moment i'm gonna comment out the scroll_to_cell. That makes the probed
row not be vertically centered, but at least it doesn't scroll horizontally.
Comment 15 Alexander Larsson 2002-08-09 08:46:07 EDT
redhat-config-xfree86 0.6.0-1 has the workaround, so i'm closing this bug, but
jrb might want to look deeper into the problem.
Comment 16 Peter van Egdom 2003-02-08 14:04:36 EST
This problem can be reproduced with redhat-config-xfree86-0.7.3-2.
I can remember it was fixed in an earlier version (I believe that was a version
of the rh-config-xfree86-0.6.x family).
Comment 17 Mike A. Harris 2003-02-08 19:08:03 EST
If the problem has returned, then feel free to reopen the report so
that it can be tracked.
Comment 18 Mattias Dahlberg 2003-02-27 03:25:25 EST
I reopen because the bug seems to have returned. I'm using Phoebe 3 and it 
looks exactly like in Peter van Egdom's screenshots.
Comment 19 Mike Chambers 2003-02-27 06:21:56 EST
I'm seeing the same thing here, on an nVidia RIVA TNT2 w/Gateway EV700 monitor.
redhat-config-xfree86-0.7.3-2
Comment 20 Brent Fox 2003-03-20 15:33:37 EST
Yes, I can reproduce this.  I showed it to Havoc and he agreed that this is
probably a bug in GTK TreeView.  Changing components and assigning to jrb.

However, it doesn't happen in the monitor dialog.  The monitor dialog is a
TreeStore whereas the videocard dialog is a ListStore.  I don't know what
difference that makes, but maybe it does.
Comment 21 Matthias Clasen 2004-05-12 14:20:42 EDT
I can't reproduce this, since system-config-display doesn't have a
"Probe" button anymore, but there is a bug about alignment issues with
gtk_cell_view_scroll_to_cell() open upstream, so I'll close this one
as UPSTREAM.

http://bugzilla.gnome.org/show_bug.cgi?id=103583

Note You need to log in before you can comment on or make changes to this bug.