Bug 68572 - Can we have cluster monitor please
Summary: Can we have cluster monitor please
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: clumanager   
(Show other bugs)
Version: 2.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-11 12:04 UTC by Paul McWatt
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-11 14:29:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul McWatt 2002-07-11 12:04:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Convolo DataGuard has a "cluster monitor" which is the same as your "cluster
status" except it automatically refreshes every 8 seconds. Can we have this with
a future release of Cluster Manager please..??

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Not Applicable
2.
3.
	

Actual Results:  With "cluster status" you have to manual refresh the view 

Expected Results:  "cluster monitor" could refresh the view automatically at an
adjustable time interval.

Additional info:

The GUI is a nice idea but not always practical. For example you could be using
telnet to make remote configuration changes so you would prefer to use the
command line inteface to get the status of the cluster. 
Nice to see the changes in status especially during demos. 
The GUI tends to be rather java heavy.

Comment 1 Lon Hohberger 2002-07-11 14:24:17 UTC
"cluster status" calls an external program called "clustat".

Perhaps what you're looking for is "clustat -i <interval>"?

There are a couple of reasons "cluster monitor" isn't present in cluadmin, the
most important is the cluadmin session lock - there can be only one copy of
cluadmin running on the cluster at a time to ensure the integrity of the cluster
configuration.  "clustat" doesn't use the session lock (because it doesn't have
the capability of modifying cluster information!).

Comment 2 Paul McWatt 2002-07-11 14:46:08 UTC
"clustat -i <interval>" provides the exact function i was looking for - thanks.


Note You need to log in before you can comment on or make changes to this bug.