This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 68573 - libxml2-devel should Require: zlib-devel
libxml2-devel should Require: zlib-devel
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: libxml2 (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-11 08:10 EDT by Thomas Vander Stichele
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-11 08:10:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Vander Stichele 2002-07-11 08:10:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
libxml2 is compiled with zlib support, so when developing apps using libxml2 the
xml2-config script pulls in -lz.
So when compiling apps without zlib-devel installed this will fail.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install a fresh system with only standard develtools, libxml2-devel,
   but no zlib-devel
2. write a simple app using libxml2
3. pull in xml2 LIBS and CFLAGS using xml2-config and try to compile
	

Actual Results:  it fails because of libz-devel missing

Expected Results:  libxml2-devel should require zlib-devel so that linking succeeds.

Additional info:

Maybe it'd be a good idea to also check if libxml2 buildrequires: zlib-devel,
and I don't know if this is the right policy, but maybe libxml2 itself should
also require zlib.
Comment 1 Daniel Veillard 2002-07-11 09:30:20 EDT
Fixed in RawHide already !

See the Requires
http://rpmfind.net//linux/RPM/rawhide/1.0/i386/RedHat/RPMS/libxml2-devel-2.4.22-2.i386.html

Daniel

Note You need to log in before you can comment on or make changes to this bug.