Bug 68603 - slow IDE on P4-M notebook with 845MP chipset
slow IDE on P4-M notebook with 845MP chipset
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-11 12:47 EDT by Bryan Che
Modified: 2014-01-21 17:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 08:55:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Che 2002-07-11 12:47:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020606

Description of problem:
I have a P4-M Compaq Presario 2800T notebook with a 60 GB ATA 100 5400 rpm hard
drive.  I have not been able to get the hard drive running in UDMA mode.

lspci gives:
00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host Bridge (rev 04)
00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP Bridge (rev 04)
00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 42)
00:1f.0 ISA bridge: Intel Corp. 82801CAM ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801CAM IDE U100 (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801CA/CAM AC'97 Audio (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW
02:04.0 Communication controller: Conexant HSF 56k HSFi Modem (rev 01)
02:06.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller
(rev 02)
02:08.0 Ethernet controller: Intel Corp. 82801CAM (ICH3) Chipset Ethernet
Controller (rev 42)
02:0e.0 USB Controller: NEC Corporation USB (rev 41)
02:0e.1 USB Controller: NEC Corporation USB (rev 41)
02:0e.2 USB Controller: NEC Corporation USB 2.0 (rev 02)

hdparm -iv /dev/hda gives:

/dev/hda:
 multcount    = 16 (on)
 I/O support  =  1 (32-bit)
 unmaskirq    =  0 (off)
 using_dma    =  0 (off)
 keepsettings =  0 (off)
 nowerr       =  0 (off)
 readonly     =  0 (off)
 readahead    =  8 (on)
 geometry     = 7752/240/63, sectors = 117210240, start = 0

 Model=IC25T060ATCS05-0, FwRev=CA8OA71A, SerialNo=CSL800D8G16EDA
 Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
 BuffType=DualPortCache, BuffSize=1768kB, MaxMultSect=16, MultSect=16
 CurCHS=17475/15/63, CurSects=16513875, LBA=yes, LBAsects=117210240
 IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes: pio0 pio1 pio2 pio3 pio4 
 DMA modes: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 *udma5 
 AdvancedPM=yes: mode=0x80 (128) WriteCache=enabled
 Drive Supports : ATA/ATAPI-5 T13 1321D revision 3 : ATA-2 ATA-3 ATA-4 ATA-5 

 busstate     =  1 (on)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1try turning on udma mode
2.
3.
	

Actual Results:  it fails

Expected Results:  it should enable it

Additional info:
Comment 1 Arjan van de Ven 2002-07-31 10:16:42 EDT
the 2.4.18-5 kernel has some i485 support; limbo will actually support i845 IDE
properly
Comment 2 Seth Vidal 2002-08-30 17:05:55 EDT
will the kernels in null rebuild cleanly on a 7.3 system?

Could I rebuild those kernels to get dma support on a machine with an 845e
chipset? or maybe 845g?
Comment 3 Arjan van de Ven 2002-08-30 17:10:04 EDT
1) yes you can rebuild them
2) no it's not a chipset thing it's a bios thing... so it doesn't too much
depend on the exact chipset as it depends on the bios
Comment 4 Seth Vidal 2002-08-30 20:38:13 EDT
is it a bios issue that has been patched by some vendors? or is it not a buggy
bios problem but a problem with the kernel interacting with the bios?
Comment 5 Alan Cox 2003-06-09 08:54:39 EDT
Current errata kernels handle this.

Note You need to log in before you can comment on or make changes to this bug.