Bug 68605 - visudo fails w/o vim-minimal installed
Summary: visudo fails w/o vim-minimal installed
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sudo   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-11 17:27 UTC by Chris Ricker
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-27 13:44:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2002-07-11 17:27:49 UTC
# visudo
visudo: no editor found (editor path = /bin/vi)
#

Either sudo needs to Require: vim-minimal (which provides /bin/vi) or visudo
needs to be changed to use `which vi` to locate vi (since it might be /bin/vi,
or it might be a shell alias for /usr/bin/vim, depending on if vim-minimal or
vim-enhanced is used)

Comment 1 Bill Nottingham 2002-07-12 04:04:20 UTC
visudo uses the defined PATH_VI from the system headers as the default, and
should (afaik) honor the EDITOR environment variables for alternate editors.

Comment 2 Chris Ricker 2002-07-12 05:25:58 UTC
It does honor EDITOR (though not VISUAL) if it's set; it's not set by default
for root on RH though

Comment 3 Chris Ricker 2002-08-24 17:01:32 UTC
still true w/ beta5

Comment 4 Karsten Hopp 2004-01-27 13:44:15 UTC
it took some time, but is finally fixed in Fedora Core 2 (development)


Note You need to log in before you can comment on or make changes to this bug.