Bug 68638 - Contents of PngSuite crashes Konqueror
Contents of PngSuite crashes Konqueror
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: kdebase (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-11 18:30 EDT by Peter van Egdom
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-15 17:24:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter van Egdom 2002-07-11 18:30:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
The Konqueror browser / filemanager crashes when the user
'touches' a .png from the PngSuite with the mouse.

The file where this happens is the file "x00n0g01.png",
which is part of the PngSuite.

This happens only when Konqueror's View Mode is on "Icon View".

On the following URL the PngSuite can be retrieved :

http://www.schaik.com/pngsuite/pngsuite.html#download

(download PngSuite.tar.gz)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download PngSuite.tar.gz from mentioned site.
2. Extract the contents of this file to some directory.
3. Start Konqueror.
4. Navigate with Konqueror to the directory where you extracted
   the contents of PngSuite.tar.gz.
5. Enable View Mode -> Icon View.
6. Point with the mouse on "x00n0g01.png".


Actual Results:  Konqueror crashed.

Expected Results:  Konqueror should have given the properties
 (size, dimensions, etc) of the .png file

Additional info:

Here's the backtrace of the crash :

 no debugging symbols found)...[New Thread 1024 (LWP 12882)]
 0x4209ce49 in wait4 () from /lib/i686/libc.so.6
 #0  0x4209ce49 in wait4 () from /lib/i686/libc.so.6
 #1  0x4211422c in __DTOR_END__ () from /lib/i686/libc.so.6
 #2  0x40ff3a43 in waitpid () from /lib/i686/libpthread.so.0
 #3  0x40717185 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
Comment 1 Ngo Than 2002-07-14 16:53:29 EDT
i cannot reproduce it in kdease-3.0.2-2.
Are you sure that the x00n0g01.png is ok? i cannot find program which can
display this file.
Comment 2 Peter van Egdom 2002-07-15 17:24:10 EDT
The file "x00n0g01.png" is a 'damaged' / corrupt .png file.
(This is done intentionally by the creator of the .PNG suite to
test the error handling of applications which can display .PNG files).

I can 100% reproduce this bug with Konqueror 3.0.2-0.cvs20020627.1.
(maybe it is fixed with a newer version, I will try this new version
 when the up2date program is working, or when the next beta is out).

(to reproduce this error, make sure the 'preview' / icon mode function of
 Konqueror is turned on..)

This time I started konqueror from a command line and got some more
info.

This info was returned to the shell by Konqueror after I pointed with
the mouse on the file "x00n0g01.png".

  libpng error: Valid palette required for paletted images
  libpng error: Valid palette required for paletted images
  libpng error: Image width or height is zero in IHDR
  libpng error: PNG file corrupted by ASCII conversion
  KCrash: crashing.... crashRecursionCounter = 2
  KCrash: Application Name = konqueror path = <unknown> pid = 3860

Comment 3 Peter van Egdom 2002-08-03 09:00:55 EDT
I could not reproduce this bug with Red Hat Linux 7.3.93 (Limbo beta 2).

It appears to be fixed in the package kdebase-3.0.2-6.

I'll close this bug.

Thanks!


Note You need to log in before you can comment on or make changes to this bug.