Bug 68652 - Switching back to metacity wm seems to be quite non-trivial operation
Summary: Switching back to metacity wm seems to be quite non-trivial operation
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-session   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords: MoveUpstream
Depends On:
Blocks: 67218 GnomeUpstream
TreeView+ depends on / blocked
 
Reported: 2002-07-12 03:32 UTC by Michal Jaegermann
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-13 02:06:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2002-07-12 03:32:34 UTC
Description of Problem:

After setting in an environment WINDOW_MANAGER to sawfish indeed this wm
is used in Limbo by session.  But reversing that turns out be not that
simple.  Neither unsetting WINDOW_MANAGER nor setting it explicitely
to 'metacity' does not have any effect.  Only after I edited manually
~/.gnome2/session (removed all lines for 'sawfish' client and decremented
'num_clients') the next session started with no window manager at all
and typing in a terminal window 'metacity' and saving setup allowed for
the next session to start with it.

Going the other way once things are recorded in ~/.gnome2/session seems
to require similar operations.  It seems possible to use a browser of
programs in a current session to kill unwanted window manager provided
one knows what "Respawn" means and how to handle this.

Comment 1 Havoc Pennington 2002-07-12 15:43:42 UTC
Ideally the way this works is that typing "metacity --replace" replaces your
current WM. That should work with fvwm2. I don't think Sawfish supports it, though.

Comment 2 Havoc Pennington 2002-12-15 18:07:45 UTC
I think the window_manager gconf key and WINDOW_MANAGER env variables should die, 
to avoid confusion; and Sawfish should support --replace; but there is no 
way the term "window manager" should be in the GUI, and I don't know a way 
to make this into a simpler operation without putting it in the GUI.

Anyhow, should all be done upstream.

Comment 3 Havoc Pennington 2002-12-16 18:21:51 UTC
Changing to MoveUpstream keyword instead of GnomeUpstream tracking bug.
sorry about the spam.


Note You need to log in before you can comment on or make changes to this bug.