Bug 68653 - Disk Partition Warning Window Won't Allow Tab Between 'No' and 'Yes'
Disk Partition Warning Window Won't Allow Tab Between 'No' and 'Yes'
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
Blocks: 67217
  Show dependency treegraph
Reported: 2002-07-11 23:40 EDT by Bob Cochran
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-07-31 22:16:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bob Cochran 2002-07-11 23:40:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
This refers to the warning window that appears when 'automatic partitioning' is
selected. Installation is being done to an older model Sony Vaio PCG-F350
laptop. The automatic partitioning warning indicates that all linux partitions
on the existing drive(s) will be deleted. The user is asked to confirm this
choice. There are two buttons, 'No' and 'Yes'. The 'No' button has the focus.
The problem is that the user cannot use the tab key to toggle the 'Yes' and 'No'
buttons, depending on preference, and then hit 'enter' to make the selection.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install Limbo on a Sony Vaio PCG-F350 laptop.
2. Select a 'laptop' class installation.
3.Arrive at the window where one makes the first disk partitioning decision.
4.Accept the default option of automatic partitioning.
5. A warning window pops up indicating all Linux partitions on the referenced
drive will be deleted and all data will be lost. There are 2 buttons the user
can click, 'No' or 'Yes'. The focus is set to the 'No' button.
6. Attempt to tab to the 'Yes' button by pressing the tab key.


Actual Results:  The window will not accept tabbing to either 'Yes' or 'No'.

Expected Results:  The user should be able to tab back and forth between these
buttons, just as with any other button in the installation program.

Additional info:

If a mouse is not connected to the machine, or if there are issues with the
mouse hardware (as seems to be quite the case with older Sony Vaio laptops using
ALPS Glidepoint touchpads), it can be difficult or impossible to continue the
installation at this point if one can't tab to the desired choice in this
warning window.
Comment 1 Michael Fulbright 2002-07-31 22:16:38 EDT
Should work now, added a mini-wm to run and set focus.
Comment 2 David Lawrence 2002-09-04 14:39:59 EDT
Verified fixed on my test system.

Note You need to log in before you can comment on or make changes to this bug.