Bug 68657 - /etc/rc.d links for apache messed up after upgrade
/etc/rc.d links for apache messed up after upgrade
Product: Red Hat Public Beta
Classification: Retired
Component: httpd (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Brian Brock
Depends On:
Blocks: 67217
  Show dependency treegraph
Reported: 2002-07-12 00:04 EDT by Jonathan Kamens
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-21 16:04:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-07-12 00:04:31 EDT
I upgraded from apache-1.3.23-11 to httpd-2.0.36-6.  The httpd service was
enabled before the upgrade.  After the upgrade, all of the httpd symlinks in
/etc/rc.d/rc*.d were gone -- both the S and K links were all gone.  To get
things back to normal I had to run "chkconfig httpd reset" and then "chkconfig
httpd on".
Comment 1 Bill Nottingham 2002-07-12 00:20:23 EDT
httpd needs a trigger. fun fun fun.
Comment 2 Preston Brown 2002-08-13 21:50:53 EDT

this is pretty critical to get fixed before beta 5.  If you need help writing
the trigger, please ask for help from Bill Nottingham (notting@redhat.com) or
Jeff Johnson (jbj@redhat.com); both have extensive trigger writing experience.
Comment 3 Bill Nottingham 2002-08-21 16:03:58 EDT
added in -2.
Comment 4 Jay Turner 2002-09-03 11:54:15 EDT
Fix confirmed with httpd-2.0.40-6.

Note You need to log in before you can comment on or make changes to this bug.