Bug 68659 - K Menu editor copy -> paste & edit problem
K Menu editor copy -> paste & edit problem
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-12 00:21 EDT by Pierre Dumuid
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:11:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Dumuid 2002-07-12 00:21:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

Description of problem:
In "Edit K Menu", I often want to copy an item, paste it at the same menu and
modify certain parts of the item, (i.e. there are now two of the same items in
that menu, with slightly different properties)
The problem is it doesn't work.. 

It pastes all right, and I can edit the properties of the pasted item to make it
different from the original item, but the new properties overwrite the original
item, and the menu doesn't show the new item up..

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Right click the K icon, and select "Menu Editor"
2. Add the following item in a directory:
   Name:      Ben's Computer
   Command:   ssh mechbsc1
   Type:      Application
   Icon:      <the one that looks like a terminal>
   Run in terminal: <selected>
 <leave all other properties empty>
3. Close the K Menu editor
4. Bring up the K Menu editor again..
5. Select the item you just added
6. Select "Copy", then "Paste" (A new item should appear)
7. Modify the new item's details as follows
   Name: John's Computer
   Command: telnet johncomp1
  <Leave the other details unchanged>


Actual Results:  From here you will see that the properties you entered into the
new item have been updated in the original item, and closing an bringing the K
menu editor up again shows the problem to have remained..

Expected Results:  The two items should be different, and closing the K menu
editor and bringing it up again should show the two items remaining intact

Additional info:
Comment 1 Petr Rockai 2006-07-17 14:34:40 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 2 Bill Nottingham 2006-10-18 14:11:48 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.