Bug 68664 - initscripts upgrade doesn't disable /proc and /proc/bus/usb in /etc/fstab
initscripts upgrade doesn't disable /proc and /proc/bus/usb in /etc/fstab
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-12 03:17 EDT by Jonathan Kamens
Modified: 2014-03-16 22:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 16:05:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-07-12 03:17:33 EDT
After upgrading to the current version of initscripts (6.82-1) and rebooting, I
got errors from mount about /proc and /proc/bus/usb already being mounted.  If
initscripts is going to take over responsibility for mounting these, then its
postinstall script needs to comment out the entries for them in /etc/fstab.
Comment 1 Bill Nottingham 2002-07-12 12:07:40 EDT
/proc is always in /etc/fstab. /proc/bus/usb never is.

What sort of system do you have?
Comment 2 Jonathan Kamens 2002-07-12 12:18:32 EDT
I could have sworn /proc/bus/usb ended up in my /etc/fstab because something had
previously added it.  In any case, even if I'm wrong about that, you still have
a problem, because /etc/rc.d/rc.sysinit is now mounting /proc.
Comment 3 Bill Nottingham 2002-07-12 12:23:47 EDT
rc.sysinit has always mounted /proc, since the dawn of time.

Something else has broken your system. :)
Comment 4 Bill Nottingham 2002-08-13 21:59:21 EDT
I *think* this was a mkinitrd bug. If you build an initrd with the latest
mkinitrd, does it behave better?
Comment 5 Jonathan Kamens 2002-08-14 06:39:29 EDT
I don't have an initrd.  I'm not sure how this could be an initrd problem -- the
basic issue is that both /etc/fstab and initscripts are trying to mount /proc.

(Although I haven't checked the current Rawhide initscripts etc. - having a new
baby in the house cuts into your free time :-)
Comment 6 Bill Nottingham 2002-08-14 13:21:59 EDT
rc.sysinit mounts proc before most anything else, and before anything using
/etc/fstab would mount it. What does your /etc/fstab look like?
Comment 7 Jonathan Kamens 2002-08-14 16:46:30 EDT
Here's the line for /proc from /etc/fstab:

none                    /proc                   proc    defaults        0 0
Comment 8 Bill Nottingham 2002-08-14 17:50:29 EDT
Where in rc.sysinit do you see these errors at?
Comment 9 Jonathan Kamens 2002-08-15 22:15:13 EDT
I'm not seeing this problem anymore with current Raw Hide after commenting out
/proc/bus/usb in /etc/fstab but leaving /proc alone (i.e., not commented out). 
I still think that there are going to be problems for people who have
/proc/bus/usb listed in their /etc/fstab.
Comment 10 Bill Nottingham 2005-09-29 16:05:45 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.