Bug 68681 - XFree86 gnome-terminal fonts look awful
XFree86 gnome-terminal fonts look awful
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: fontconfig (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
David Lawrence
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-12 11:26 EDT by Horst H. von Brand
Modified: 2007-04-18 12:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 23:23:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2002-07-12 11:26:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
Toshiba Satellite 1800 notebook (1024x768 generic display). The fonts for
gnome-terminal look hoorible, almost unreadable. The font emacs uses is very
legible on the same machine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open gnome terminal
2.
3.
	

Actual Results:  Almost unreadable fonts

Expected Results:  On RH 7.3 the fonts look fine



Additional info:

A note on the 'net says this might be due to not installing the XFree86 75 and
10o dpi fonts, both are installed here.
Comment 1 Mike A. Harris 2002-07-12 17:44:03 EDT
Owen, Havoc:  Known issue?
Comment 2 Owen Taylor 2002-07-12 17:54:06 EDT
Without a screenshot I can't really say.

It's not an XFree86 problem in any case. Reassigning to fontconfig
until we get more information.

Comment 3 Preston Brown 2002-08-21 23:23:00 EDT
I'm sure it is the issue of the fixed terminal font being anti-aliased and not
looking quite as good as the bitmapped terminal fonts.  Can we possibly switch
to a bitmapped terminal font?
Comment 4 Owen Taylor 2002-08-22 08:02:04 EDT
I believe that this was probably a problem with fontconfig
finding the XFree86-truetype-fonts versions of the Luxi fonts
rather than the Type1 versions, and the rendering of the
TrueType versions was *much* worse. This has been fixed
now by removing that directory from the fontconfig font
path.

(While people might think that the AA fonts we are using
now look fuzzy, or not too their taste, I doubt they
would be described as "hoorible, almost unreadable".
The way the TrueType versions rendered 1-2 months ago
would fit that description.)

I'd rather keep our default terminal font AA like the
rest of the desktop ... there are definite effects where 
the eye prefers *consistent* contrast, rather than maximum
possible contrast. (I'm not sure the mechanism
for this is understood ... it may just be that one
instinctively adjusts ones viewing distance from the screen
to the optimal distance for a certain type of rendering.)

Note You need to log in before you can comment on or make changes to this bug.