Bug 68683 - RFE: Please add support for prism2 wireless adapters
RFE: Please add support for prism2 wireless adapters
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-12 11:31 EDT by ajs
Modified: 2007-04-18 12:44 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-19 11:40:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ajs 2002-07-12 11:31:23 EDT
Description of Problem:

Please add support for the Prism2 drivers found at http://www.linux-wlan.org/
Comment 1 Arjan van de Ven 2002-07-12 11:32:52 EDT
prism2 hardware is supposed to be already supported... can you give model info
on your card that isn't supported?
Comment 2 Warren Togami 2002-07-13 10:04:31 EDT
prism2 is partially supported by the wvlan_cs.o and orinoco_cs.o drivers, but
there are a few prism2 cards like my SMC2632W that are totally non-functional
with either driver.  It defaults to wvlan but fails completely.  orinoco_cs
appears to work, but fails with tons of transmit errors and completely unable to
get a single UDP packet through.  Strangely the SMC2602W PCI adapter (which is a
2632W card in a PLX adapter) works 90% of the time with the orinoco_plx driver.

The drivers at the linux-wlan project much better support my adapters than the
drivers included in Red Hat, as well as other prism2 cards including the USB
versions.  Please do consider including those drivers into Limbo.
Comment 3 ajs 2002-07-15 10:27:16 EDT
The Siemens SpeedStream 1022 USB adaptor does not work and neither does the
Linksys WMP11.
Comment 4 ajs 2002-07-15 10:35:16 EDT
I forgot to mention that the Wireless HOWTO drivers page
(http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Linux.Wireless.drivers.html)
has recently been updated.  See section 10 for the linux-wlan drivers.  The
HostAP mode drivers in section 12 are also nice, but less critical for my use.
Comment 5 ajs 2002-07-23 13:03:35 EDT
There are RPMs of the previous release of the linux-wlan drivers at
http://prism2.unixguru.raleigh.nc.us/.  These integrate well with Red Hat 7.3
and might be a good starting place for getting familiar with the drivers.
Comment 6 Josh Wyatt 2002-07-23 13:34:16 EDT
Current distro support seems to be limited to a subset of PCMCIA prism2
devices.  USB, PCI, PLX, and many PCMCIA adapters based on the prism2 chipset
are only supported by linux-wlan.
I've been using the linux-wlan drivers for awhile, and they seem to be stable. 
The only issue I've seen is with high-throughput, and that happens rarely.
Comment 7 Tim Miller 2002-07-23 14:18:28 EDT
As maintainer of the RPMS on the prism2 raleigh site list above,
I would be happy to donate the packages (spec, patches, etc)
to RedHat for them to include it (and of course modify, warp, 
and shred it as needed).  Feel free to contact me offline to
discuss this as necessary.
Comment 8 Need Real Name 2002-07-23 19:15:31 EDT
I've used these drivers for several revisions on an IBM ThinkPad A30p, with an
integrated Actiontec wlan. Solid code. I works very well. I dig it.  It makes
sense to add this support to RH. 

Regards; 

Eric Wilson
RHCE
IBM CATE
Comment 9 Need Real Name 2002-07-24 13:45:34 EDT
Agreed.  I'm using these drivers with a Linksys card on an IBM Thinkpad 600E 
running Red Hat 7.3, and they are rock solid.  I have never experienced a drop 
off with these drivers, unlike the drivers I have for my Winbook running WinXP 
which drops 3 times during an 8 hour work day.  

Including these drivers in the next distro would make me go out and actually 
purchase a copy of Red Hat, something I haven't done since 6.2 (but was 
tempted to do after using 7.3 for a while).
Comment 10 xml 2002-08-14 08:09:16 EDT
I use the Prism2 driver here: http://hostap.epitest.fi/ which can also allow
your prism2 card to act as an AP. hostap_pci and hostap_plx could be compiled to
support people with inbuilt prism2 cards such as the one on my thinkpad X22,
independently of the driver you chose for PCMCIA. If you don't use PCMCIA, it
takes 1 minute to compile and install.

*Please* at least supply hostap_pci if nothing else, you'll earn the thanks of
many laptop users with mini-pci 802.11 cards.
Comment 11 Mark Allen 2002-12-13 18:18:53 EST
I love me too comments; but Red Hat really needs to provide a lot better Prism 2
support out of the box.  The wvlan drivers are okay for casual use, but they
don't support all the cards out there nor do they support WEP (which while
broken is at least useful to turn on, if only to keep casual people from
hijacking your bandwidth)

Please consider integrating either a) an updated version of the wvlan driver
with better Prism 2 support or b) the wlan-ng drivers into your kernels builds.
 The problem using the wlan-ng drivers right now is that it's hard to keep up
with all the kernel errata.
Comment 12 Lamar Owen 2003-01-25 15:08:20 EST
Linksys WPC11 works well with Tim Miller's wlan-ng packages; stock Red Hat 
kernel drivers do not work at all. 
Comment 13 Jeremy Portzer 2003-01-27 17:27:10 EST
Regarding Comment #12, the Linksys WPC11 card can be made to work in Psyche
using orinoco_cs.o with a simple config change.  See Bug #76305 .
Comment 14 Bill Nottingham 2003-02-19 11:40:27 EST
We aren't adding linux-wlan-ng anytime soon. HostAP is being investigated.
Comment 15 Josh Wyatt 2003-02-19 11:54:14 EST
Just a clarification, the HostAP project has no provision for using cards with
this chipset as a *host* (i.e., station), only as an access point.
wlan-ng and hostap don't do the same thing. (although wlan-ng does have some
access point functionality).

The general rule is:
1. If you want to make your prism2 card/machine behave as an access point, you
use HostAP
2. If you want your prism2 card/machine to be a wireless client, you use wlan-ng

It seems as though you guys (RedHat) are not interested in supporting prism2 as
a wireless client, only as an access point...?
Comment 16 xml 2003-02-19 12:09:13 EST
> the HostAP project has no provision for using cards with
> this chipset as a *host* (i.e., station), only as an access point.

It certainly does allow the use as client only.
Comment 17 Murray Cumming 2003-04-21 03:19:14 EDT
> We aren't adding linux-wlan-ng anytime soon.

Can you explain this, please? I'm sure you have your reasons, but it would be
nice to know what they are.

Note You need to log in before you can comment on or make changes to this bug.