Bug 68686 - 2.4.18-5 kernel does not have radeon DRM module
Summary: 2.4.18-5 kernel does not have radeon DRM module
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-12 15:42 UTC by Tim Miller
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-13 08:02:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Miller 2002-07-12 15:42:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020606

Description of problem:
When upgrading my RH7.3 kernel from 2.4.18-3 to 2.4.18-5, I lost
direct rendering on my IBM Thinkpad A30 (Radeon Mobility).  I
traced the issue to kernel modules that did not load because
they were not PRESENT in the kernel package.


Version-Release number of selected component (if applicable): 2.4.18-5


How reproducible:
Always

Steps to Reproduce:
/lib/modules# find . -name "radeon*"
./2.4.18-3/kernel/drivers/char/drm/radeon.o
./2.4.18-3/kernel/drivers/video/radeonfb.o
./2.4.18-5/kernel/drivers/video/radeonfb.o



Actual Results:  When booting 2.4.18-5, chromium game is painfully slow.  Graphics
are jerky and unplayable.  When booting 2.4.18-3 (NO OTHER CHANGES),
chromium game plays just fine.

Additional info:

Comment 1 Arjan van de Ven 2002-07-12 15:46:43 UTC
Ok I bet the following is the case:

you installed the i386 kernel (instead of the i586, i686 or athlon one)

the i386 kernel doesn't have DRM support, the i586, i686 or athlon kernels DO
have DRM support....

is my assumption correct ?

Comment 2 Tim Miller 2002-07-12 23:08:33 UTC
That was the problem.  I didn't realize I had installed the i386
kernel for one thing but I also didn't think it mattered.  Why
isn't DRM in i386?  (I am by far NOT a video guru)



Comment 3 Arjan van de Ven 2002-07-13 08:02:05 UTC
The DRM code internally uses CPU instructions that are not available on a
80386......


Note You need to log in before you can comment on or make changes to this bug.