Bug 68692 - No destination MAC address in message
Summary: No destination MAC address in message
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-12 15:56 UTC by Jack Bloch
Modified: 2015-03-05 01:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-15 19:52:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jack Bloch 2002-07-12 15:56:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
I use SIOCSARP to force a permanent IP/MAC combination into the ARP cache. The 
first message I try to send to this device (using UDP/IP) contains 
00:00:00:00:00:00 in the destination MAC address field. Subsequent messages are 
correct. A display of the ARP cache prior to the send shows the entry.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Force IP/MAC combination into ARP cache
2.Send UDP packet to the destination host
3.Look at message on sniffer
	

Additional info:

Comment 1 Jack Bloch 2002-07-15 19:52:36 UTC
Please close this trouble report, the problem was caused by my own device 
driver which I have subsequently corrected.


Note You need to log in before you can comment on or make changes to this bug.