Bug 68696 - Customized HTTP error messages are overwritten during upgrade
Customized HTTP error messages are overwritten during upgrade
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: squid (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-12 12:12 EDT by Bill Smargiassi
Modified: 2014-03-16 22:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-12 12:12:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Smargiassi 2002-07-12 12:12:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530

Description of problem:
First, this is a RedHat packaging error. Not a bug in squid.

Every time we upgrade squid we lose our locally customized error messages. This
has happened from as far back as we have been using the RedHat version of the
squid RPM, at least 6.0 I think. The files in /etc/squid/errors should be
designated as config files such that the vanilla ones from the RPM are created
as *.rpmnew instead of overwriting any changed files. I think they need to be
the specified the same as the /etc/squid/squid.conf file in the spec file.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Modify a file in /etc/squid/errors
2. Upgrade squid from an errata

	

Actual Results:  All HTTP error messages revert to the plain-vanilla squid samples.

Expected Results:  Our locally customized files should not be overwritten. The
plain-vanilla versions should be saved as *.rpmnew

Additional info:
Comment 1 Bill Nottingham 2002-07-18 22:25:26 EDT
If you want to customize them, make a new directory, and point the
/etc/squid/errors symlink there; the symlink should be preserved on upgrade.

Note You need to log in before you can comment on or make changes to this bug.