Bug 68707 - Mailman w/Postfix gid woes
Mailman w/Postfix gid woes
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mailman (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
: 50744 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-12 13:41 EDT by Kyle Rhorer
Modified: 2007-04-18 12:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-05 17:27:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyle Rhorer 2002-07-12 13:41:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux; i686)

Description of problem:
Mailman as deliverd with RHL 7.x is apparently compiled --with-mail-gid='mail' which probably works with Sendmail.  However, when using Postfix as the MTA, that configuration of Mailman won't work.  Possible fixes: compile Postfix to use gid 'mail' or split mailman into mailman-core, mailman-sendmail, and mailman-postfix.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RHL with Postfix as MTA instead of Sendmail
2. Install Mailman binary RPM
3. Attempt to make Mailman work
 

Actual Results:  Attempts to send mail to a Mailman-managed list return the well-known gid mismatch error.

Expected Results:  Should have worked without incident

Additional info:

This problem can be resolved by compiling Mailman from SRPM with --with-mail-gid='mailman', but that presupposes that gcc and supporting packages have been installed.  Not necessarily the case on a stripped-down single-purpose server.  Plus, it shouldn't be necessary for the user to recompile.
Comment 1 Chris Ricker 2003-01-10 02:02:51 EST
*** Bug 50744 has been marked as a duplicate of this bug. ***
Comment 2 Chris Ricker 2003-04-26 08:51:58 EDT
This is fixed in RHL 8.0 / 9, isn't it?
Comment 3 John Dennis 2003-04-28 10:49:41 EDT
Actually I don't think it is if I understand the issue. I believe that postfix
runs as the user/group 'postfix' and this is not in the list of mail users in
the mailman spec file. Adding it would be trivial.
Comment 4 John Dennis 2003-05-05 17:27:25 EDT
added postfix to list of groups, time to close this out, should be in
mailman-2.1.2-*

Note You need to log in before you can comment on or make changes to this bug.