Bug 68708 - Format string errors in translation-strings
Format string errors in translation-strings
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-12 13:43 EDT by Enrico Scholz
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-12 13:44:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against recent CVS version (3.23 KB, patch)
2002-07-12 13:44 EDT, Enrico Scholz
no flags Details | Diff

  None (edit)
Description Enrico Scholz 2002-07-12 13:43:11 EDT
I will attach a patch fixing several format-string errors in the po/*.po files.

In ko.po I removed two messages because I do not know how to fix them; in pl.po
and is.po I added format-elements but because I do not speak these languages I
do not know if these are the correct places.


A lot of .po files are having incorrect headers which are failing to work with
recent rawhide-gettext. Does it make sense to send patches (which are just
adding correct charsets and *removing* default strings) or are the .po files
maintained at another place?
Comment 1 Enrico Scholz 2002-07-12 13:44:17 EDT
Created attachment 65165 [details]
Patch against recent CVS version
Comment 2 Jeff Johnson 2002-07-12 16:35:49 EDT
The po files for rpm are maintained at cvs.rpm.org.
SInce that's a different location than all other
Red Hat sources, the po files often are not made
available for translation through "normal"
channels.

In general, patches with PO files are tricky,
so significant changes should include the
entire file, not a patch.

Thanks for noticing and sending the patch
however :-) Should be in rpm-4.1-0.47 when
built.

Note You need to log in before you can comment on or make changes to this bug.