Bug 68717 - cannot run up2date in command line mode
Summary: cannot run up2date in command line mode
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-12 19:49 UTC by Frank Baier
Modified: 2015-01-07 23:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 20:55:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frank Baier 2002-07-12 19:49:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
In Console mode (no X installed) I've got only:

No interactive mode available
Please specify either -l, -u, --nox, or package names as comma d line 
arguments.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run up2date 
2.
3.
	

Additional info:

Comment 1 Adrian Likins 2002-07-12 19:52:20 UTC
does "up2date -u" or "up2date -l" not work?

Comment 2 Frank Baier 2002-07-16 21:11:54 UTC
up2date -l and -u will work but no other parameter. I want only to download 
the rpm's!!! I think that it will be faild because a rpm is missing but all 
dependencies are ok!!!

Comment 3 Adrian Likins 2002-07-16 21:58:29 UTC
Not sure I understand. non gui up2date is designed to be used
non-interactively, so the the "-u" mode will download and
install the packages you need to be upgraded.

`up2date -ud` will just download the packages you need to
be up to date.

Comment 4 Frank Baier 2002-07-17 05:05:29 UTC
And Why will up2date -d not work? I work with all RH Releases in the last 2-3 
years an it will work. are there additional or other parameters? I don't know 
exactly because a can't validate it now, but I think that it worked also on RH 
7.3 but not on my Computer!!! What is different between -d and -ud? I
-ud make the same things like -u



Comment 5 Adrian Likins 2003-01-21 03:11:18 UTC
Is this still a problem?

Comment 6 Adrian Likins 2004-04-05 20:55:57 UTC
closing,works with current releases


Note You need to log in before you can comment on or make changes to this bug.