Bug 6872 - slip connects show false failure
slip connects show false failure
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-10 02:36 EST by culliton
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 14:13:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description culliton 1999-11-10 02:36:22 EST
This is a system upgraded from 6.0 to 6.1 with rp3-1.0.1-1,
ppp-2.3.10-3, initscripts-4.63-1 and all other errata
updates. I deleted my slip devices (which have never worked
right) and added them back with netcfg since rp3-config
crashes immediately (presumably due to one of the previously
reported problems).

Starting sl0 from the usernet/rp3 console tool gets an
immediate falure notification despite the fact that the dip
script is happily dialing in and connecting in the
background.  Of course since rp3 thinks that the connect
failed, it can't be used to shut down the connection once
it's established...  (dip -k to the rescue!)

There seem to be couple things here, slip doesn't seem to be
well supported or tested, and dial-in configurations created
with netcfg seem to give rp3 minor heartburn.  Sorry if this
is slightly vague, more details as I track them down and
record them.
Comment 1 culliton 1999-11-10 02:56:59 EST
OK here's something interesting, every time it bombs /var/log/messages
shows:

Nov 10 02:51:33 culliton-ppp modprobe: can't locate module sl0
Nov 10 02:51:33 culliton-ppp modprobe: can't locate module sl1
Comment 2 Michael K. Johnson 1999-11-19 16:32:59 EST
You are right, to be honest, about slip being the ugly stepchild here.
That's mainly because dip is so incredibly inflexible in ways that it
would have to be flexible to make this work well.  It just does not
give us the functionality we need to make ifup work properly in this
context, and there are few enough slip users that I spent my time
improving PPP rather than re-architecting dip...

There's some code to make wvdial work for SLIP, and I may try to make
use of that in the future to make SLIP connections work better.  That
uses slattach and would allow me, if it works reliably, to get rid of
dip entirely for setting up SLIP connections.
Comment 3 culliton 1999-11-19 17:17:59 EST
I think you've got the priorities right, SLIP is primarily a compatibility tool
for older systems, we only use it to do dial up networking with old AIX 3.2
systems.  Still, it would be nice if it worked from the usernet/rp3 GUI.  I have
dip scripts that work, but have to run them from a shell window as root.  What
exactly is the incompatibility between dip and rp3?  Maybe my nasty twisty mind
can help...
Comment 4 Michael K. Johnson 1999-11-22 16:32:59 EST
It's not so much an incompatibility as a complete difference...

rp3 doesn't explicitly know about dialing.  It just stores some
values in /etc/sysconfig/network-scripts/ifcfg-ppp<n> and
/etc/wvdial.conf and that's it, as far as configuration goes.
The wvdial intelligent dialer is the program actually doing
the dialing underneath the covers.
Comment 5 Brent Fox 2002-06-05 00:56:00 EDT
Closing because we don't ship rp3 anymore.

Note You need to log in before you can comment on or make changes to this bug.