Bug 68738 - Gdialog missing from gnome-utils again
Summary: Gdialog missing from gnome-utils again
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-utils   
(Show other bugs)
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-13 06:31 UTC by W. Michael Petullo
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-08 06:03:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description W. Michael Petullo 2002-07-13 06:31:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020625

Description of problem:
Gdialog is very useful in nautilus scripts but is missing from gnome-utils-2.0.0-4.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  gdialog
	

Actual Results:  bash: gdialog: command not found

Expected Results:  Gdialog should run.

Additional info:

See also bug number 54415.  A similar bug was submitted and fixed for a previous
Red Hat Linux release.

Comment 1 Havoc Pennington 2002-07-13 14:15:18 UTC
This time the situation is a bit different, as gdialog is disabled upstream due
to lack of maintenance. We could enable it but I don't know if it works. I'm
assuming someone turned it off for a reason.

Comment 2 W. Michael Petullo 2002-07-20 14:32:55 UTC
I just started using the gdialog included in GNOME's 2.0.0 gnome-utils
distribution.  In order to use it, one needs to configure gnome-utils with
"./configure --enable-gdialog=yes."  It has been working fine with what I use it
for, but I plan on asking its developers why it is disabled by default. 
Nautilus scripts really need gdialog.

Comment 3 W. Michael Petullo 2002-07-27 08:59:44 UTC
I asked the GNOME folks about this and they reponded by adding the following to
gnome-utils' README file:

[ Gdialog is ] not built by default as the Gtk+ port is incomplete and needs
much attention. We would dearly love to bring this back building - please help
us fix it.

Hmm...

Works fine for me.  ldd `which gdialog`:

[...]
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x4019e000)
[...]

I suspect I am not exercising all of gdialog's features.  I'll play around and
see if I can flush out and fix its bugs.

Comment 5 Adrian Miranda 2002-10-08 01:11:24 UTC
The return value of gdialog --yesno seems to be incorrect.  For example, if I
select Yes, the exit value is 248.  This is with the released version of redhat 8.0.

Comment 6 Havoc Pennington 2002-10-08 01:44:20 UTC
Yes, it's broken. That's why it was turned off. People begged to have it on, now
it's there, it's broken. Amazing! ;-)

It's fixed on the GNOME 2.2 branch I believe.

Comment 7 Havoc Pennington 2003-01-08 06:03:48 UTC
I guess this bug should have been closed, as we turned gdialog on.


Note You need to log in before you can comment on or make changes to this bug.