Bug 68749 - X fails badlywith Xconfigurator-generated XF86Config (MediaGX)
X fails badlywith Xconfigurator-generated XF86Config (MediaGX)
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-07-13 09:58 EDT by Telsa Gwynne
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-24 12:36:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2002-07-13 09:58:48 EDT
Milan beta3, TUI install. MediaGX chip (sorry!) with 2Mb video RAM and 
96Mb of RAM

Ran Xconfigurator. There some some other issues which I am doing 
separately, but the upshot was that with the MediaGX selected, I
said "yes, test it" and got Bad Things. It appeared as though it 
had almost managed it, only at a much lower resolution. I saw
hazy images of the desktop icons over the top left quarter of 
the screen with random colours elsewhere before it gave up and
(we think) tried to go back to the console. It failed to get
mode switching right, and I had to reboot (soft reboot, though,
with control-alt-delete) to restore things.

It got the monitor details perfectly right. I had to select just
about everything else and came up with
MediaGX, 2Mb video RAM, no clock chip, resolution 16x1024x768.

A second run with same selections except for VESA instead of 
Media GX worked. (Incidentally, anaconda auto-selected VESA
and the video memory, so that got it right. Although the anaconda-
generated XF86Config wasn't perfect: it wouldn't start X)

The bug here is the MediaGX driver failing and the mode switching
(whatever that is) failing. Should this be in XFree86-Servers?
Not seen that category before.
Comment 1 Mike A. Harris 2002-07-14 05:58:31 EDT
We really need to remove Xconfigurmessinator.  ;o)

You got the right category though.  Xfree86-Servers is 3.3.6, which is now
gone.  Will investigate.
Comment 2 Mike A. Harris 2004-09-24 12:36:18 EDT
Hi Telsa,

I think Alan fixed these issues quite a while back, and this bug
probably just got left open.  I'm going to assume it's fixed for
now and close as "CURRENTRELEASE", but if the problem occurs
again with Fedora Core 2 or a later test release, etc. please
reopen, and we'll poke Alan with a stick a few times.  ;o)

Note You need to log in before you can comment on or make changes to this bug.