Bug 68781 - rpm --verify errors immediately after installing XFree86-truetype-fonts
rpm --verify errors immediately after installing XFree86-truetype-fonts
Status: CLOSED DUPLICATE of bug 68933
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-13 22:20 EDT by Jonathan Kamens
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-14 05:18:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-07-13 22:20:17 EDT
jik:/usr/lib/rpm!290> rpm --verify XFree86-truetype-fonts                      
               missing    /usr/X11R6/lib/X11/fonts/TTF/encodings.dir
missing    /usr/X11R6/lib/X11/fonts/TTF/fonts.alias
.M...... g /usr/X11R6/lib/X11/fonts/TTF/fonts.scale
jik:/usr/lib/rpm!291> rpm -q XFree86-truetype-fonts                            
         
XFree86-truetype-fonts-4.2.0-52.01
jik:/usr/lib/rpm!292> 

As far as I know, I havne't made any modifications to the files owned by this
package that might require me to have different local versions of these files,
so there shouldn't be any errors from rpm --verify.
Comment 1 Mike A. Harris 2002-07-14 05:18:07 EDT
fonts.scale is generated at install time and is a transient file.
fonts.alias does not exist in the distribution, however, it is a valid
file which *could* exist should a user create one in that directory, in
which case the package is set to own the file.  The fonts.alias file is
NOT considered a config file, since config files upon upgrade get either
renamed to .rpmsave, or the new version gets .rpmnew and we both don't want
that to happen, and there is no need for it to happen.  "missingok" is
the flag that would be relevant in this case, however that flag is not
relevant except for config files which fonts.alias is not for these
purposes IMHO.

So, I'm not sure how this should be handled, if at all, since RPM does
not seem to have flags to flag these files in the way they need to be
flagged.  I'll leave the bug report open in case someone else has a
better idea of how to deal with it.  One possibility I can think of
is to remove the %ghost fonts.alias file entirely and make it unowned.
That would then leave any fonts.alias file created by the user unowned
by any package and an uninstall would make the directory unremovable.

The fonts.scale file however is 100% transient and not a statically owned
or installed file.  It is generated post install, and whenever else
the xfs initscript or some other event causes it to be regenerated, so
the MD5sum for it is irrelevant.
Comment 2 Mike A. Harris 2002-07-24 05:18:50 EDT
Closing as dupe of 68933 for tracking

*** This bug has been marked as a duplicate of 68933 ***

Note You need to log in before you can comment on or make changes to this bug.