Bug 68783 - old version included, while new and improved version exists
old version included, while new and improved version exists
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: gnuplot (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
: FutureFeature
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-13 22:39 EDT by Dmitri A. Sergatskov
Modified: 2014-03-16 22:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-15 12:56:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri A. Sergatskov 2002-07-13 22:39:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
This version is awfully old. Please include 3.8 instead
(with pm3d and mouse support). As of this moment 3.8i
is as stable as a "stable" version. "Conectiva" had it for
quite some time already.


Version-Release number of selected component (if applicable): 3.7.1


How reproducible:
Always

Steps to Reproduce:
1.run 'gnuplot'
2.
3.
	

Actual Results:  G N U P L O T
        Linux version 3.7
        patchlevel 1


Expected Results:   G N U P L O T
        Version 3.8i patchlevel 0
:)

Additional info:
Comment 1 Bill Nottingham 2002-07-14 20:32:09 EDT
URL?

The latest official release I see is 3.7.2, released in March of this year.
Comment 2 Dmitri A. Sergatskov 2002-07-14 21:24:16 EDT
It has not been released yet. But it is as stable as anything. You 
need to get a CVS snapshot per instructions on
http://sourceforge.net/cvs/?group_id=2055

Here is Hans-Bernhard Broeker (broeker@physik.rwth-aachen.de) take on a release
schedule:
http://groups.google.com/groups?q=gnuplot+release+3.8&hl=en&lr=lang_en&ie=UTF-8&oe=UTF-8&scoring=d&as_drrb=b&as_mind=1&as_minm=1&as_miny=2002&as_maxd=14&as_maxm=7&as_maxy=2002&selm=ad7qv9%24qim%241%40nets3.rz.RWTH-Aachen.DE&rnum=4
<<<
Thomas Willert <T.Willert@gga-hannover.de> wrote:
> I've found a gzip tarball of version 3.7.2 at the DANTE server as well as a
> one of version 3.8 under testing subdirectory.  

3.7.2 was originally meant as a quick-fix release for the benefit of
Debian Linux.  We never made that any more official because soon after
its finalization, build problems on other platforms popped up. 

> Are there plans to release a new version and binaries yet? 

Expect a full release of 3.7.3 (including pre-built binary packages,
and a prominent announcement, too) pretty soon now.  This is mainly a
bugfix release with some minor improvements (including some new
terminal drivers), but no major new features.

> Which improvements are developed actually?

From 3.7.1 to the next "real" release (4.0): too many to list them
here.  3.8 is the development series meant to become 4.0.  There's no
schedule for the release of 4.0, but it will probably happen this
year.

-- 
Hans-Bernhard Broeker (broeker@physik.rwth-aachen.de)
Even if all the snow were burnt, ashes would remain
>>>
Comment 3 Bill Nottingham 2002-07-15 11:04:25 EDT
Sorry, we really aren't going to ship snapshots of the development series. We'll
add the latest stable release; this could be 3.7.3 or 4.0 if it's released in time.
Comment 4 Dmitri A. Sergatskov 2002-07-15 12:56:44 EDT
And why is that? You did it with other stuff. And there are "released" packages
that much more qualify for "alpha" release and yet they are included. 

Gnuplot team is famous for procrastinating the releases (look at 3.5 -> 3.7
release), the 3.8 has significan improvements to the user interface 
(mouse support for x11 terminal). Gnuplot is being used as a plotting engine by 
many programs (e.g. octave). The fact that many distributions are holding 
back on this 3.7 release forces maintainers of other gnuplot-dependent packages
to hold on it as well. 

I sincerely hope you re-consider your stance on it.
Comment 5 Bill Nottingham 2002-07-18 19:48:30 EDT
It is our general policy to not ship software that upstream maintainers do not
feel is ready; if they don't believe it's ready enough for a stable realease, we
should not ship it.

Note You need to log in before you can comment on or make changes to this bug.