Bug 68792 - not writing NETWORKING=no into /etc/sysconfig/network
not writing NETWORKING=no into /etc/sysconfig/network
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-14 06:43 EDT by Michael Schwendt
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-24 18:07:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2002-07-14 06:43:29 EDT
Description of problem:
Anaconda writes "NETWORKING=yes" into /etc/sysconfig/network, if network support
is installed. But when network support is not installed, it should write
NETWORKING=no, because various initscripts rely on the availability of such a
definition.


Version-Release number of selected component (if applicable):
7.3.92-4

How reproducible:
Always

Steps to Reproduce:
Perform fresh installation without network support. Look at
/etc/sysconfig/network afterwards.

Actual Results:  Should contain NETWORKING=no.

Expected Results:  Does not contain NETWORKING=no.


Additional info:

A related bug exists in redhat-config-network, which does not write
NETWORKING=yes if network support components are added after installation and
the network is configured.
Comment 1 Michael Fulbright 2002-07-24 18:07:22 EDT
What do you mean when 'no networking support is installed'?

You mean if there are no ethernet ports on the machine?
Comment 2 Michael Schwendt 2002-07-24 21:36:20 EDT
https://listman.redhat.com/pipermail/valhalla-list/2002-July/008137.html

Sorry, it should have been filed against Valhalla. I'm unable to reproduce it
with Limbo, neither with a minimal installation. Even when no Ethernet device is
installed, it puts "NETWORKING=yes".

Note You need to log in before you can comment on or make changes to this bug.