Bug 68806 - ignore_services bug in logwatch secure script
Summary: ignore_services bug in logwatch secure script
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: logwatch (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-14 17:25 UTC by Jay Berkenbilt
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-14 17:26:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to correct problem (413 bytes, patch)
2002-07-14 17:26 UTC, Jay Berkenbilt
no flags Details | Diff

Description Jay Berkenbilt 2002-07-14 17:25:56 UTC
Description of Problem:

secure.conf has a variable "$ignore_services" which is case-insensitive.  The
case-insensitivity is achieved by converting its contents to all lower-case.
The secure script fails to do a case-insensitive match.  This makes it
impossible to exclude a service that puts its name in the log with any
upper-case letters.

Version-Release number of selected component (if applicable):

logwatch-2.6-2

How Reproducible:

Always

Steps to Reproduce:
1. Try to exclude a service in secure.conf (e.g. Pluto) that logs its name with
a capital letter

Actual Results:

The line is not omitted from the secure log.

Expected Results:

It should have been.

A one-line patch to fix the problem is attached.

Comment 1 Jay Berkenbilt 2002-07-14 17:26:22 UTC
Created attachment 65308 [details]
patch to correct problem

Comment 2 Elliot Lee 2002-08-08 15:54:33 UTC
applied


Note You need to log in before you can comment on or make changes to this bug.