Bug 68824 - RFE: include option to eject CD-ROM before final step of installation
RFE: include option to eject CD-ROM before final step of installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-14 17:33 EDT by Peter van Egdom
Modified: 2011-05-10 15:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-12 11:12:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter van Egdom 2002-07-14 17:33:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
When the installation of Red Hat Linux is complete, the installation program
hints about removing the floppy disk and all other boot media.

But when the user completes the installation and removes the floppy disk,
the user cannot remove the CD because it is still mounted.

If the user wants to remove the CD-ROM he has to finish the installation
wait until the PC responds to the CD-ROM drive, quickly press the eject
button on the CD-ROM device and remove the Red Hat CD.

When the quickboot function of the PC is turned on the user has about 4
seconds to remove the CD from the CD-ROM drive. :-)

Would it be better to have a modification in that last procedure of the 
installation as follows :

 - Installer hints about removing floppies and CD's.
 - Installer unmounts all removable devices and does a "eject"
   on the device from which Red Hat is installed.

   - *** System ejects CD-ROM ***

 - User removes floppy and CD and puts CD safely in jewel case.
 - Installer displays a message and asks for a keypress to reboot
   the system.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat Linux.
2. ... until you're at the final stage.
3. Installer tells about removing boot media.
	

Actual Results:  
While being in the installer I cannot remove the CD from the CD-ROM device,
because the drive is still mounted.

I then press the 'quit' button of the installer and quickly press the eject 
button before the PC closes the CD tray again due to the BIOS initialisation
of some PC's.

Sometimes the CD gets scratched because of the quick eject and close mechanism
of the CD-ROM tray.


Expected Results:
I expected that the installer unmounts and ejects the CD from the CD-ROM drive
so I can safely put it in the jewel case.

Additional info:
Comment 1 Jeremy Katz 2002-07-25 01:32:13 EDT
Deferring to a future release

Note You need to log in before you can comment on or make changes to this bug.