Bug 688359 - [JBPAPP-6103] EWS 1.0.2-CR1 + JON 2.4.1: Tomcat virtual host config save fails - "InstanceNotFoundException: Catalina:type=StoreConfig"
[JBPAPP-6103] EWS 1.0.2-CR1 + JON 2.4.1: Tomcat virtual host config save fail...
Status: CLOSED DUPLICATE of bug 583996
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
3.0.0
Unspecified Unspecified
medium Severity unspecified (vote)
: ---
: ---
Assigned To: Stefan Negrea
Mike Foley
:
Depends On:
Blocks: ews1.0.2
  Show dependency treegraph
 
Reported: 2011-03-16 17:15 EDT by Ondřej Žižka
Modified: 2012-10-10 18:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-10 18:02:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondřej Žižka 2011-03-16 17:15:53 EDT
1) Install EWS, JON, get Tomcat 6 monitored.
2) Go to "localhost" virtual host, CONFIGURATION tab
3) Change it's setting, e.g. unpack WAR's, save
4) Saving fails, with the following exception.

JMX was not secured and was working, e.g. JVM stats were displayed correctly.



---------------------------------------------------------------------
Mar 15, 2011 3:08:10 PM org.apache.tomcat.util.modeler.BaseModelMBean invoke
SEVERE: Exception invoking method storeConfig
javax.management.InstanceNotFoundException: Catalina:type=StoreConfig
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getMBean(DefaultMBeanServerInterceptor.java:1094)
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:833)
at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:761)
at org.apache.catalina.core.StandardServer.storeConfig(StandardServer.java:641)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.tomcat.util.modeler.BaseModelMBean.invoke(BaseModelMBean.java:297)
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:836)
at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:761)
at javax.management.remote.rmi.RMIConnectionImpl.doOperation(RMIConnectionImpl.java:1427)
at javax.management.remote.rmi.RMIConnectionImpl.access$200(RMIConnectionImpl.java:72)
at javax.management.remote.rmi.RMIConnectionImpl$PrivilegedOperation.run(RMIConnectionImpl.java:1265)
at javax.management.remote.rmi.RMIConnectionImpl.doPrivilegedOperation(RMIConnectionImpl.java:1360)
at javax.management.remote.rmi.RMIConnectionImpl.invoke(RMIConnectionImpl.java:788)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:305)
at sun.rmi.transport.Transport$1.run(Transport.java:159)
at java.security.AccessController.doPrivileged(Native Method)
at sun.rmi.transport.Transport.serviceCall(Transport.java:155)
at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:535)
at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(TCPTransport.java:790)
at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:649)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:662)
Comment 1 Ondřej Žižka 2011-03-16 17:18:13 EDT
Note that unlike BZ#583996, this is for virtual host, not whole tomcat.
But it might write to the same file (server.xml), or even invoke the same action (flush whole config to server.xml).
Comment 2 Ondřej Žižka 2011-03-16 17:18:49 EDT
Bug 583996 ^^
Comment 5 Charles Crouch 2011-10-19 09:14:14 EDT
I think this is a dupe as discussed below
Comment 6 Charles Crouch 2012-10-10 18:02:47 EDT
Closing as a dupe of BZ-583996. That bug has the better description of the underlying issue.

*** This bug has been marked as a duplicate of bug 583996 ***

Note You need to log in before you can comment on or make changes to this bug.