Bug 688361 - esc fails to start
Summary: esc fails to start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: esc
Version: 15
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jack Magne
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-16 21:23 UTC by Alon Levy
Modified: 2014-08-04 22:08 UTC (History)
12 users (show)

Fixed In Version: esc-1.1.0-14.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-07 02:35:40 UTC
Type: ---


Attachments (Terms of Use)

Description Alon Levy 2011-03-16 21:23:25 UTC
Description of problem:
esc doesn't start in F15. When run from command line, this is the output:

Could not find compatible GRE between version 1.9 and 1.99.
Could not find compatible GRE between version 1.9 and 1.99.


Version-Release number of selected component (if applicable):
esc-1.1.0-12.fc14.x86_64

How reproducible:
100%

Steps to Reproduce:
1. start terminal, run esc in it
  
Actual results:
fails to load, gives above message

Expected results:
start as usual

Additional info:

Comment 1 Jack Magne 2011-03-17 01:23:45 UTC
Thank you.

This is due to the new Gecko SDK 2.0. Shortly I will have it up and running on Xulrunner 2.0.

Comment 2 Jack Magne 2011-03-28 16:54:14 UTC
Completed build esc-1.1.0-14-fc15

Program now launches and detects keys under Gecko 2.0. More testing needed.

Comment 3 Alon Levy 2011-03-28 18:54:23 UTC
ok, installed, starts fine, works fine, so far so good. Just one warning (no crash) - when I hover over the icon in the message tray (bottom right - I am running F15 with the default gnome-shell) I get the following warning whenever the tooltip is displayed (it repeats four times):

(esc:18067): Gdk-CRITICAL **: IA__gdk_window_get_root_coords: assertion `GDK_IS_WINDOW (window)' failed

Comment 4 Jack Magne 2011-03-28 19:02:04 UTC
Thank you , yes I noticed that too. Did not have time to figure that out.

Comment 5 Fedora Update System 2011-03-29 00:17:13 UTC
esc-1.1.0-14.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/esc-1.1.0-14.fc15

Comment 6 Fedora Update System 2011-03-29 03:32:25 UTC
Package esc-1.1.0-14.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing esc-1.1.0-14.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/esc-1.1.0-14.fc15
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-04-15 21:54:49 UTC
esc-1.1.0-14.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Danilo Câmara 2011-07-13 18:23:31 UTC
Not working in updated Fedora 15:
esc-1.1.0-14.fc15.x86_64
xulrunner-5.0-2.fc15.x86_64

'esc' exits without any message, 'esc --help' outputs:

$ esc --help
Could not find compatible GRE between version 1.99 and 2.99.
Could not find compatible GRE between version 1.99 and 2.99.

$ xulrunner --gre-version
5.0

Comment 9 Jack Magne 2011-07-13 19:18:04 UTC
Thanks:

The Gecko version must have progressed past a magic number.. Will take care of it.

Comment 10 Danilo Câmara 2011-08-16 15:56:20 UTC
Shouldn't this bug have it's Status changed from "CLOSED ERRATA"?

Comment 11 brian.broussard 2011-09-15 20:36:52 UTC
2.6.38.8-35.fc15.i686.PAE
esc-1.1.0-14.fc15.i686
xulrunner-6.0.2-1.fc15.i686
coolkey-1.1.0-19.fc15.i686

xulrunner --gre-version
6.0.2

Card reader SCR331
Bus 004 Device 004: ID 04e6:e001 SCM Microsystems, Inc. SCR331 SmartCard Reader

from the command line run esc
insert card
Could not find compatible GRE between version 1.99 and 2.99.

esc --help 
Could not find compatible GRE between version 1.99 and 2.99.
Could not find compatible GRE between version 1.99 and 2.99.

Is there any resolution? 
thanks

Comment 12 Jack Magne 2011-09-15 23:56:14 UTC
Hi:

Try this build:

http://koji.fedoraproject.org/koji/buildinfo?buildID=253829

thanks,
jack

Comment 13 brian.broussard 2011-09-16 12:55:24 UTC
2.6.38.6-26.rc1.fc15.i686.PAE #1 SMP Mon May 9 20:36:50 UTC 2011 i686

esc-1.1.0-15.fc15.i686
xulrunner-6.0.2-1.fc15.i686
coolkey-1.1.0-19.fc15.i686

insert card
Could not find compatible GRE between version 1.99 and 2.99.

esc --help 
Could not find compatible GRE between version 1.99 and 2.99.
Could not find compatible GRE between version 1.99 and 2.99.

xulrunner --gre-version
6.0.2



esc 1.1.0-15 did not help!

Comment 14 Danilo Câmara 2011-09-16 13:26:00 UTC
Not working for me too (2.6.40.4-5.fc15.x86_64)

Comment 15 Jack Magne 2011-09-16 17:48:56 UTC
OK:

Thanks for the info.

I see you have the 6.0 Gecko, what version of Firefox have you got as well?


One quick thing you can try with build 15 is this:

Edit /usr/lib/esc-1.1.0/application.ini

Change the setting MaxVersion=

to something greater than 6.

Give it a try.

thanks.

Comment 16 brian.broussard 2011-09-16 18:15:46 UTC
firefox-6.0.2-1.fc15.i686

changed MaxVersion=10.99


esc --help 
Could not find compatible GRE between version 1.99 and 10.99.
Could not find compatible GRE between version 1.99 and 10.99.

Comment 17 Danilo Câmara 2011-09-16 21:44:36 UTC
This is the current (updated) Fedora 15 version. Now with the faster release cycle of Firefox, Fedora is often updating firefox and xulrunner packages.

Comment 18 Jack Magne 2011-09-16 23:11:13 UTC
Yes, thanks. I have done a quick look and figured out what the issue is. Even more changes to the SDK since 2.0. Will fix it.

Comment 19 brian.broussard 2011-09-20 13:59:40 UTC
Thanks looks like it is working will be doing an end to end test later this week. 

Quick questions?  the windows version of this fix where may I locate it?

Comment 20 phatgeek 2011-11-18 19:52:04 UTC
Is this still open? I'm confused because according to the header, this is "Fixed In Version:  esc-1.1.0-14.fc15"; however, it is not working for me with esc-1.1.10-14.fc15.x86_64.rpm installed.

# esc
Could not find compatible GRE between version 1.99 and 2.99.
Could not find compatible GRE between version 1.99 and 2.99.

I have xulrunner-7.0.1-1.fc15.x86_64.rpm installed.

# xulrunner --gre-version
7.0.1

Did not try the esc-1.1.10-15.fc15 version since it did not appear to work for the other users, above.

~Rich

Comment 21 phatgeek 2011-11-18 19:54:10 UTC
Typo -- sorry.  the version of esc I have installed is obviously esc-1.1.0-14.fc15, but it still doesn't work.
(In reply to comment #20)

Comment 22 Jack Magne 2011-11-18 20:38:25 UTC
The version that works is in brew, the build system. Working on getting that moved. thanks

Comment 23 Fedora Update System 2011-11-30 19:41:44 UTC
esc-1.1.0-14.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/esc-1.1.0-14.fc16

Comment 24 Henry Leinhos 2012-01-20 20:07:08 UTC
I installed esc-1.1.0-14.fc16 on my fresh FC16 install (i686), and when I put my CAC in the card reader ESC complains with the dialog:

Can't Get UniversalXPConnect.TypeError:  Components.class['@redhat.com/rhCoolKey;1'] is undefined

coolkey.GetAvailableCoolKeys() failed! undefined(undefined)


$ rpm -q coolkey
coolkey-1.1.0-19.fc15.i686
$ rpm -q esc
esc-1.1.0-14.fc16.i686


pcsc_scan sees the card properly, though:

pcsc_scan 
PC/SC device scanner
V 1.4.17 (c) 2001-2009, Ludovic Rousseau <ludovic.rousseau@free.fr>
Compiled with PC/SC lite version: 1.6.6
Scanning present readers...
0: SCM SCR 331 [CCID Interface] (50507D26) 00 00

Fri Jan 20 15:05:44 2012
 Reader 0: SCM SCR 331 [CCID Interface] (50507D26) 00 00
  Card state: Card inserted, Shared Mode, 
  ATR: 3B 7D 96 00 00 80 31 80 65 B0 83 11 13 AC 83 00 90 00

ATR: 3B 7D 96 00 00 80 31 80 65 B0 83 11 13 AC 83 00 90 00
+ TS = 3B --> Direct Convention
+ T0 = 7D, Y(1): 0111, K: 13 (historical bytes)
  TA(1) = 96 --> Fi=512, Di=32, 16 cycles/ETU
    250000 bits/s at 4 MHz, fMax for Fi = 5 MHz => 312500 bits/s
  TB(1) = 00 --> VPP is not electrically connected
  TC(1) = 00 --> Extra guard time: 0
+ Historical bytes: 80 31 80 65 B0 83 11 13 AC 83 00 90 00
  Category indicator byte: 80 (compact TLV data object)
    Tag: 3, len: 1 (card service data byte)
      Card service data byte: 80
        - Application selection: by full DF name
        - EF.DIR and EF.ATR access services: by GET RECORD(s) command
        - Card with MF
    Tag: 6, len: 5 (pre-issuing data)
      Data: B0 83 11 13 AC
    Tag: 8, len: 3 (status indicator)
      LCS (life card cycle): 00 (No information given)
      SW: 9000 (Normal processing.)

Possibly identified card (using /usr/share/pcsc/smartcard_list.txt):
3B 7D 96 00 00 80 31 80 65 B0 83 11 13 AC 83 00 90 00
	CAC card (GEMALTO GCX4 72K DI)

Comment 25 Jack Magne 2012-01-20 22:12:47 UTC
Will check it out. Thanks for the report.

Comment 26 Leroy Hall 2012-02-11 23:45:23 UTC
Any update on this issue?  I am attempting to perform cac login with the same error.

Comment 27 Leroy Hall 2012-02-12 00:00:20 UTC
Forgot to say that I am utilizing FC16 and have the same error as Henry's last post.

Comment 28 Henry Leinhos 2012-02-13 13:49:23 UTC
I'd like to add that on CAC insertion, the error show up as dialogs, but esc seems to run, just not see the card (while pcsc_scan clearly shows that pscsd should see it).

Comment 29 Jack Magne 2012-02-14 02:45:07 UTC
Hello.

Sorry for the delay. I just tried this out myself on an F16 box. Using the build esc-1.1.0-14.fc16.i686.


I used the SCR331 reader with two different CAC's, axalto access 64k, and gemalto top 144.

I was able to get both those recognized just fine.

Sample output:

SMART CARD DIAGNOSTICS REPORT

***Software Version Information***

 Smart Card Manager Version: 1.1.0-14.fc16
 System Versions: mozilla/5.0 (x11; linux i686; rv:8.0) gecko/20100101 esc/1.1.0-16

***Active Smart Card Details***

  Number of Smart Cards Detected: 1

Smart Card  CARD.TESTER.xxxxxx:

One quick thing to check.

Perhaps the esc user profile may have at some point become corrupted.
May want to try this just to test:

rm -rf ~./redhat/esc and try again.

  Smart Card Applet Version: 0.0
  Key ID:  CARD.TESTER.XXXXX           
  Status:  Enrolled
  Issuer: xxx
  Atr:  xxxxx
  Phone Home URL:  
  Smart Card Server URL:  
  Enrollment UI URL:

Comment 30 Jack Magne 2012-02-14 02:55:34 UTC
One more thing, could you guys post the xulrunner version?

Comment 31 Leroy Hall 2012-02-14 03:18:06 UTC
xulrunner-10.0-1.fc16.i686  I am using the default xulrunner version. 

Leroy

Comment 32 Leroy Hall 2012-02-14 03:20:00 UTC
Even when running that Command I received this error 
Can't get UniversalXPConnect.TypeError: Components.classes['@redhat.com/rhCoolKey;1'] is undefined

Comment 33 Leroy Hall 2012-02-14 03:22:46 UTC
Can't get UniversalXPConnect.TypeError: netkey is undefined

Comment 34 Henry Leinhos 2012-02-14 13:27:34 UTC
Hmmm.

Diagnostics from esc say:

 SMART CARD DIAGNOSTICS REPORT

***Software Version Information***

 Smart Card Manager Version: null
 System Versions: mozilla/5.0 (x11; linux i686; rv:10.0) gecko/20100101 esc/1.1.0-16

***Active Smart Card Details***

  Number of Smart Cards Detected: 0


***Smart Card Activity***
No log file or log file has no data.



I notice that my system version has mozilla/5.0 (x11; linux i686; rv:10.0)
but Jack's has (x11; linux i686; rv:8.0).

Is that significant?


BTW, 
Removing ~/.redhat/esc had no effect, and I have
xulrunner-10.0-1.fc16.i686

I am running gnome3 shell (not fallback), if it matters...

Comment 35 Jack Magne 2012-02-14 18:15:17 UTC
Thanks:

I'll check out the xulrunner discrepancy. Thanks for the info.

For those simply but not showing the card in the diagnostics, running pcscd in the foreground with logging might help shed provide some info.

su
service pcscd stop
/usr/sbin/pcscd -d -f -a

thanks,
jack

Comment 36 Jack Magne 2012-02-21 02:16:13 UTC
Figured out problem with respect to the latest xulrunner. Working on build.

Comment 37 Jack Magne 2012-02-23 02:44:15 UTC
Those that are interested can try out the build here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=300867

Comment 38 Henry Leinhos 2012-02-23 13:35:34 UTC
It works!

Thanks Jack!

Comment 39 Leroy Hall 2012-02-25 07:07:38 UTC
works like a Champ Jack.  You are the man!!!!!

Comment 40 Patrick C. F. Ernzer 2012-02-28 10:54:06 UTC
on x86_64 I get
[pcfe@morn ~]$ esc
[pcfe@morn ~]$ 
** (xulrunner-bin:12223): WARNING **: Can not stat /tmp/orbit-pcfe

XPCOMGlueLoad error for file /usr/lib/xulrunner-2/libxpcom.so:
/usr/lib/xulrunner-2/libxpcom.so: cannot open shared object file: No such file or directory

on x86_64 the library is at /usr/lib64/xulrunner-2/libxpcom.so

Comment 41 Patrick C. F. Ernzer 2012-02-28 10:57:28 UTC
hmm, scratch comment 40, when I start esc via GUI it comes up fine.

Comment 42 Fedora Update System 2012-03-10 03:17:14 UTC
esc-1.1.0-15.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/esc-1.1.0-15.fc16

Comment 43 Fedora Update System 2012-03-10 21:51:09 UTC
Package esc-1.1.0-15.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing esc-1.1.0-15.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3535/esc-1.1.0-15.fc16
then log in and leave karma (feedback).

Comment 44 Joel 2012-03-22 16:14:32 UTC
upgraded to the version of esc in updates-testing.  When inserting a CAC I get a pop-up that says

"Can't get UniversalXPConnect.TypeError: Components.classes['@redhat.com/rhCoolKey;1']"

When hitting "OK" it pops-up:

"coolkey.GetAvailableCoolKeys() failed! undefined(undefined)"

hitting "OK" again and no smart cards are listed even though pcsc_scan shows the card.

Comment 45 travis mallet 2012-04-09 23:49:48 UTC
I keep getting the same error.

Mozilla XULRunner 11.0 - 20120313114517
# uname -a
Linux aris 3.3.1-3.fc16.x86_64 #1 SMP Wed Apr 4 18:08:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

When I insert the card or run esc-1.1.0-15.fc16 get the following messages.


Can't get UniversalXPConnect.TypeError: Components.classes['@redhat.com/rhCoolKey;1'] is undefined

coolkey.GetAvailableCoolKeys() failed! undefined(undefined)

When I exit I get.

Can't get UniversalXPConnect.TypeError: netkey is undefined

e TypeError: Components.classes['@redhat.com/rhTray;1'] is undefined

The diagnostic output:
SMART CARD DIAGNOSTICS REPORT

***Software Version Information***

 Smart Card Manager Version: null
 System Versions: mozilla/5.0 (x11; linux x86_64; rv:11.0) gecko/20100101 esc/1.1.0-15

***Active Smart Card Details***

  Number of Smart Cards Detected: 0


***Smart Card Activity***
No log file or log file has no data.

Mon Apr  9 19:37:04 2012
 Reader 0: Generic CCID Reader [CCID Interface] 00 00
  Card state: Card inserted, 
  ATR: 3B DB 96 00 80 1F 03 00 31 C0 64 B0 F3 10 00 07 90 00 80

ATR: 3B DB 96 00 80 1F 03 00 31 C0 64 B0 F3 10 00 07 90 00 80
+ TS = 3B --> Direct Convention
+ T0 = DB, Y(1): 1101, K: 11 (historical bytes)
  TA(1) = 96 --> Fi=512, Di=32, 16 cycles/ETU
    250000 bits/s at 4 MHz, fMax for Fi = 5 MHz => 312500 bits/s
  TC(1) = 00 --> Extra guard time: 0
  TD(1) = 80 --> Y(i+1) = 1000, Protocol T = 0 
-----
  TD(2) = 1F --> Y(i+1) = 0001, Protocol T = 15 - Global interface bytes following 
-----
  TA(3) = 03 --> Clock stop: not supported - Class accepted by the card: (3G) A 5V B 3V 
+ Historical bytes: 00 31 C0 64 B0 F3 10 00 07 90 00
  Category indicator byte: 00 (compact TLV data object)
    Tag: 3, len: 1 (card service data byte)
      Card service data byte: C0
        - Application selection: by full DF name
        - Application selection: by partial DF name
        - EF.DIR and EF.ATR access services: by GET RECORD(s) command
        - Card with MF
    Tag: 6, len: 4 (pre-issuing data)
      Data: B0 F3 10 00
    Mandatory status indicator (3 last bytes)
      LCS (life card cycle): 07 (Operational state (activated))
      SW: 9000 (Normal processing.)
+ TCK = 80 (correct checksum)

Possibly identified card (using /root/.smartcard_list.txt):
3B DB 96 00 80 1F 03 00 31 C0 64 B0 F3 10 00 07 90 00 80
        DoD CAC, Oberthur ID One 128 v5.5 Dual

I do notice the it says my card reader is DoD CAC, Oberthur ID One 128 v5.5 Dual. It is not it is a SCM Microsystems scr3310v2.0.

Comment 46 Jack Magne 2012-04-10 01:43:03 UTC
OK thanks.

The problem is fixed for xulrunner 10. Will need to do a rebuild for 11 and it should work.

Comment 47 Peter Zagar 2012-05-04 13:18:43 UTC
GUI works with latest build, but still unusable due to errors. See travis mallet's post above. I'm getting the exact same errors.

Comment 48 Jack Magne 2012-05-04 16:44:26 UTC
Thank you.

Still working on that issue.

Comment 49 Fedora Update System 2012-05-11 01:36:56 UTC
esc-1.1.0-16.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/esc-1.1.0-16.fc16

Comment 50 Fedora Update System 2012-05-11 01:38:30 UTC
esc-1.1.0-16.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/esc-1.1.0-16.fc17

Comment 51 Jack Magne 2012-05-11 01:41:48 UTC
The f16 and f16 builds require Firefox/Xulrunner 12.

Comment 52 Fedora Update System 2012-06-07 02:35:40 UTC
esc-1.1.0-16.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 53 Fedora Update System 2012-06-07 02:53:57 UTC
esc-1.1.0-16.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 54 Paulo Fessel 2012-06-07 17:01:17 UTC
Does not work for me. Starting esc gives:

Can't get UniversalXPConnect.TypeError: Components.classes['@redhat.com/rhCoolKey;1'] is undefined

and after clicking OK:

coolkey.GetAvailableCoolKeys() failed! undefined(undefined)

After this, I get "no cards present". 

Clicking diagnostics gives the very same error messages above. Here are the contents of the debug window:

SMART CARD DIAGNOSTICS REPORT

***Software Version Information***

 Smart Card Manager Version: null
 System Versions: mozilla/5.0 (x11; linux x86_64; rv:13.0) gecko/20100101 esc/1.1.0-16

***Active Smart Card Details***

  Number of Smart Cards Detected: 0


***Smart Card Activity***
No log file or log file has no data.

pcsc_scan returns:

PC/SC device scanner
V 1.4.17 (c) 2001-2009, Ludovic Rousseau <ludovic.rousseau@free.fr>
Compiled with PC/SC lite version: 1.7.4
Scanning present readers...
0: MSI StarReader SMART [Smart Card Reader Interface] (20070818000000000) 00 00

Thu Jun  7 13:59:43 2012
 Reader 0: MSI StarReader SMART [Smart Card Reader Interface] (20070818000000000) 00 00
  Card state: Card inserted, Shared Mode, 
  ATR: 3B B2 11 00 10 80 00 08

ATR: 3B B2 11 00 10 80 00 08
+ TS = 3B --> Direct Convention
+ T0 = B2, Y(1): 1011, K: 2 (historical bytes)
  TA(1) = 11 --> Fi=372, Di=1, 372 cycles/ETU
    10752 bits/s at 4 MHz, fMax for Fi = 5 MHz => 13440 bits/s
  TB(1) = 00 --> VPP is not electrically connected
  TD(1) = 10 --> Y(i+1) = 0001, Protocol T = 0 
-----
  TA(2) = 80 --> Protocol to be used in spec mode: T=0 - Unable to change - defined by interface bytes
+ Historical bytes: 00 08
  Category indicator byte: 00 (compact TLV data object)
    Error in the ATR: expecting 3 bytes and got 1

Possibly identified card (using /usr/share/pcsc/smartcard_list.txt):
3B B2 11 00 10 80 00 08
        Atmel memory card AT88SC0808C
        http://www.atmel.com/dyn/resources/prod_documents/doc5210.pdf
        Smart VR Card - GD Burti

The card has been identified correctly. Is this an error of the esc?

Comment 55 Fedora Update System 2012-06-22 22:50:35 UTC
esc-1.1.0-17.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/esc-1.1.0-17.fc16

Comment 56 Fedora Update System 2012-06-22 22:51:37 UTC
esc-1.1.0-17.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/esc-1.1.0-17.fc17

Comment 57 maverick.pt 2012-08-16 15:06:45 UTC
I still have this problem on FC17 (64 bits).

Should i open a new bug?

Comment 58 Jack Magne 2012-08-16 16:58:07 UTC
Try this one:

http://koji.fedoraproject.org/koji/buildinfo?buildID=345573

Working it through the system.

This bug is fine.

Comment 59 maverick.pt 2012-08-16 19:51:59 UTC
Nope, same error with that one.

Comment 60 Jack Magne 2012-08-16 22:54:38 UTC
I've tested this to work on my f17 box, with firefox/xulrunner 14.0.1-1.fc17.x86_64. Is this what you have on yours?

Comment 61 maverick.pt 2012-08-17 06:52:43 UTC
Yes.

firefox-14.0.1-1.fc17.x86_64
xulrunner-14.0.1-3.fc17.x86_64


Note You need to log in before you can comment on or make changes to this bug.