Bug 688569 - [NV98] My computer's monitor doesn't wake up after suspend.
Summary: [NV98] My computer's monitor doesn't wake up after suspend.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-17 11:43 UTC by Canol Gökel
Modified: 2018-04-11 16:18 UTC (History)
6 users (show)

Fixed In Version: kernel-2.6.38-4.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-07 20:19:22 UTC


Attachments (Terms of Use)
Xorg.x.log file (34.70 KB, text/plain)
2011-03-18 13:38 UTC, Canol Gökel
no flags Details
Output of the dmesg command (123.47 KB, text/plain)
2011-03-18 13:38 UTC, Canol Gökel
no flags Details
/var/log/messages file (3.28 MB, text/plain)
2011-03-18 13:46 UTC, Canol Gökel
no flags Details
vbios.rom file (64.00 KB, text/plain)
2011-03-21 00:34 UTC, Canol Gökel
no flags Details

Description Canol Gökel 2011-03-17 11:43:39 UTC
Description of problem:
My computer's monitor doesn't wake up after suspend. I'm not sure if everything else wakes up but the hard disk, fans and other LEDs seem to indicate that the computer woke up.

How reproducible:
Always


Steps to Reproduce:
1. Suspend the computer using either user menu or closing the lid.
2. Open the lid or press the power button


Actual results:
Hard disk and fans seem to be working but monitor is completely black.


Additional info:
My computer is Lenovo 3000 G530
Graphics card: nVidia GeForce 9300M GS
It is dual boot with Windows and on Windows this problem is not present.

I'm using the nouveau driver. I tried nVidia propriatery drivers, and the monitor wakes up, though the graphics are messed up and unreadable.

Although I'm currently testing Fedora 15 Alpha with latest updates, this problem is present since at least Fedora 12, and not only on Fedora but all other distributions I have tested like Ubuntu.

Comment 1 Matěj Cepl 2011-03-17 22:55:44 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Canol Gökel 2011-03-18 13:38:03 UTC
Created attachment 486240 [details]
Xorg.x.log file

Comment 3 Canol Gökel 2011-03-18 13:38:40 UTC
Created attachment 486241 [details]
Output of the dmesg command

Comment 4 Canol Gökel 2011-03-18 13:46:45 UTC
Created attachment 486243 [details]
/var/log/messages file

Comment 5 Ben Skeggs 2011-03-20 23:33:34 UTC
I can see one very good reason for this in your logs, I'll take a look at implementing the missing piece today and get back to you!  Hopefully it's only the one issue :)

Comment 6 Ben Skeggs 2011-03-21 00:13:01 UTC
Actually, can you do the following for me:

1. sudo mount -t debugfs debugfs /sys/kernel/debug
2. sudo cp /sys/kernel/debug/dri/0/vbios.rom ~/

And then upload ~/vbios.rom to this bug please.

Comment 7 Canol Gökel 2011-03-21 00:34:19 UTC
Created attachment 486527 [details]
vbios.rom file

Comment 8 Canol Gökel 2011-03-21 00:40:10 UTC
Hi,

Thank you for your effort. I added the vbios.rom file.

I switched back to Fedora 14 64-Bit this morning after a crash on Fedora 15 Alpha. I'm still using nouveau driver and this bug is also present here (Fedora 14) would you want me to update the first 3 file I've uploaded?

Comment 9 Ben Skeggs 2011-03-22 22:15:39 UTC
I've submitted a new kernel which will hopefully help you along a bit more.  It's available at http://koji.fedoraproject.org/koji/buildinfo?buildID=235008.

I was not able to test the patch, as I don't have any cards which use the vbios table opcode yours is using.  But, if you can resume now, I guess it's working :)

Comment 10 Canol Gökel 2011-03-22 22:38:02 UTC
Is there a way I can test it on my Fedora 14? I switched back to Fedora 14 after a crash made my computer unbootable, though the bug exists here as well :(

Comment 11 Ben Skeggs 2011-03-22 22:44:14 UTC
I think you *should* be able to install that kernel on F14 for long enough to test it.  I'd rather have the fix confirmed before pushing it into the stable distro.

Comment 12 Canol Gökel 2011-03-22 23:01:42 UTC
Ok, I tried it. I get a SELinux error but other than that IT WORKS! Thank you million times! The SELinux alert I get is below, should I report it in a different bug report?

SELinux is preventing /usr/sbin/wpa_supplicant from using the sys_module capability.

*****  Plugin sys_module (99.5 confidence) suggests  *************************

If you do not believe that /usr/sbin/wpa_supplicant should be attempting to modify the kernel by loading a kernel module.
Then a process might be attempting to hack into your system.
Do
contact your security administrator and report this issue.

*****  Plugin catchall (1.49 confidence) suggests  ***************************

If you believe that wpa_supplicant should have the sys_module capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep wpa_supplicant /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:NetworkManager_t:s0-s0:c0.c1023
Target Context                system_u:system_r:NetworkManager_t:s0-s0:c0.c1023
Target Objects                Unknown [ capability ]
Source                        wpa_supplicant
Source Path                   /usr/sbin/wpa_supplicant
Port                          <Unknown>
Host                          canol-fedora
Source RPM Packages           wpa_supplicant-0.6.8-10.fc14
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.7-31.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     canol-fedora
Platform                      Linux canol-fedora 2.6.38-4.fc15.x86_64 #1 SMP Tue
                              Mar 22 09:47:58 UTC 2011 x86_64 x86_64
Alert Count                   2
First Seen                    Wed 23 Mar 2011 12:54:27 AM EET
Last Seen                     Wed 23 Mar 2011 12:56:03 AM EET
Local ID                      1071a5a3-b0b4-4a06-946c-554ae929369c

Raw Audit Messages
type=AVC msg=audit(1300834563.857:25033): avc:  denied  { sys_module } for  pid=1178 comm="wpa_supplicant" capability=16  scontext=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 tcontext=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 tclass=capability


type=SYSCALL msg=audit(1300834563.857:25033): arch=x86_64 syscall=ioctl success=no exit=ENODEV a0=8 a1=8933 a2=7fff5038d030 a3=e84ecab5131ba4f8 items=0 ppid=1 pid=1178 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=wpa_supplicant exe=/usr/sbin/wpa_supplicant subj=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 key=(null)

Hash: wpa_supplicant,NetworkManager_t,NetworkManager_t,capability,sys_module

audit2allow

#============= NetworkManager_t ==============
allow NetworkManager_t self:capability sys_module;

audit2allow -R

#============= NetworkManager_t ==============
allow NetworkManager_t self:capability sys_module;

Comment 13 Ben Skeggs 2011-03-23 00:21:30 UTC
Thank you for testing!  Glad it works :)

I wouldn't worry about the SELinux issue.  I don't know much about the area, but perhaps it's just a result of using F15's kernel with F14's userspace.

Were you planning on staying with F14?  If so, I can probably backport the fix to F14's kernel also.

Comment 14 Canol Gökel 2011-03-23 06:13:50 UTC
Yes, I will probably use F14 for a few more months... Thanks again...

Comment 15 Ben Skeggs 2011-03-23 07:16:37 UTC
This link points to the F14 kernel with the relevant patch applied.

http://koji.fedoraproject.org/koji/taskinfo?taskID=2935408

It should finish building in the next hour or so.

Comment 16 Fedora Update System 2011-03-24 10:54:23 UTC
kernel-2.6.38.1-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.38.1-6.fc15

Comment 17 Canol Gökel 2011-03-25 07:54:20 UTC
Hello, I just tried the last kernel you build for Fedora 14 and I can confirm that it works as well. The SELinux problem does not occur either. So it is perfect right now.

Comment 18 Fedora Update System 2011-03-28 05:18:09 UTC
kernel-2.6.38.2-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.38.2-8.fc15

Comment 19 Fedora Update System 2011-03-31 20:02:22 UTC
kernel-2.6.38.2-8.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora End Of Life 2012-08-07 20:19:24 UTC
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.