Bug 688603 - oocalc fails to start while the quickstarter is running
oocalc fails to start while the quickstarter is running
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-17 09:29 EDT by Horst H. von Brand
Modified: 2011-03-18 09:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-18 09:56:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2011-03-17 09:29:26 EDT
Description of problem:
I'm running XFCE, there some Gnome applications work funny.

I tried to open a CSV file via "oocalc xxx.csv", the "import file" window opened, I could select the options I wanted, but then nothing whatsoever.

Later I tried "oocalc something.xls", nothing. Plain "oocalc" or "Open file"/"New spreadsheet" from the quickstarter gave nothing.

I looked around, and "pgrep soffice" found two processes, one soffice and a soffice.bin. Believing they were somehow stuck, I killed the first one (it seems to have been the quickstarter), and tried again to open the .xls, which succeded.

Version-Release number of selected component (if applicable):
libreoffice-calc-3.3.1.2-6.fc15.x86_64

How reproducible:
Seemingly always

Steps to Reproduce:
1. oocalc somefile.xls
2.
3.
  
Actual results:
Program returns immediately

Expected results:
Open the spreadsheet

Additional info:
I've got LOo crashes, but to report them via abrt I've to download some 800 MiB (!) of debug info, which installs to 3 GiB or so (!!). Will see if it gets the right versions this round..
Comment 1 Horst H. von Brand 2011-03-17 10:18:28 EDT
I installed the debuginfo packages as told, but the backtrace turns out unusable all the same :-(
Running abrt-gui, it is now getting an extra set of debuginfos (?)...
Comment 2 Horst H. von Brand 2011-03-17 10:27:56 EDT
Two rounds of "debuginfo-install libreoffice-core" gave no usable backtrace, and no missing debuginfos.
Comment 3 Horst H. von Brand 2011-03-17 15:18:27 EDT
I stand corrected: Something really was wedged, starting oocalc (and others) restarted the Quickstarter, and now it works as intended.
Comment 4 Caolan McNamara 2011-03-17 16:26:08 EDT
I have no control over debuginfo packages or abrt unfortunately. So, is there now a known reproducible scenario here that I can do something about ?
Comment 5 Horst H. von Brand 2011-03-18 09:22:35 EDT
I just tried again, now it works fine. Just that if I do "oocalc somefile.ods" the program exits immediately (but a window shows up soon).

Seems I've wasted your time here... :-(
Comment 6 Caolan McNamara 2011-03-18 09:56:04 EDT
I'm sure there is a bug in here somewhere, but its a matter of fighting battles again reproducible enemies :-)

Note You need to log in before you can comment on or make changes to this bug.