Bug 688634 - EC2 RHEL5.5 AMIs do not include the redhat-lsb package
EC2 RHEL5.5 AMIs do not include the redhat-lsb package
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: releng (Show other bugs)
All Linux
high Severity high
: ---
: ---
Assigned To: Jay Greguske
wes hayutin
: EC2, Regression
Depends On:
  Show dependency treegraph
Reported: 2011-03-17 11:16 EDT by Pierre Carrier
Modified: 2011-10-11 17:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-10-11 17:19:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Pierre Carrier 2011-03-17 11:16:32 EDT
Description of problem:
- The redhat-lsb package is not included in EC2 RHEL5.5 AMIs

Version-Release number of selected component (if applicable):

Additional info:
- This prevents from using lsb_release, common within deployment tools to establish the distribution name and version
- It was installed in the 5.4 images
Comment 1 wes hayutin 2011-03-21 11:08:43 EDT
adding Jay to the bug
Comment 2 wes hayutin 2011-03-22 07:15:16 EDT
Are the following two rpms also required? I noticed they are installed in the RHEL 6 ami's
Comment 3 Jay Greguske 2011-03-28 11:46:52 EDT
Customer asked for redhat-lsb to be installed so I'm just going to add that for now. -graphics and -printing do not sound like they belong on an EC2 image.

I added redhat-lsb to the package list in the 5.5 and 5.6 kickstart files. (5.7 will come from 5.6 when that beta starts up)

Confirmed that RHEL 6 already has redhat-lsb installed. Additionally, -graphics and -printing do not appear to depend on anything, so I'm not sure what they're for. I added llim (Brew says he is the maintainer) to the bug for some advice.
Comment 4 Lawrence Lim 2011-03-28 12:13:44 EDT
redhat-lsb was split to graphics and printing so that user that does not require desktop or desktop features do not have to install the LSB dependencies that goes with it (gnome, qt4, etc). If minimal feature is required, the core package should be suffice.
Comment 5 Jay Greguske 2011-10-11 17:19:47 EDT
Fixed a long time ago.

Note You need to log in before you can comment on or make changes to this bug.