Bug 688701 - DOCS: cman_tool "expected" option is to vague
DOCS: cman_tool "expected" option is to vague
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.7
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Lon Hohberger
Cluster QE
: ManPageChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-17 14:46 EDT by Shane Bradley
Modified: 2011-07-21 03:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: cman-2.0.115-81.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 03:25:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shane Bradley 2011-03-17 14:46:58 EDT
Description of problem:
The man page for "cman_tool" is to vague for the "expected" option and
should contain more detail on the "expected" option. I propose that the
current text be replaced with something like this:

$ man cman_tool
....
SUBCOMMANDS
   expected 
       Tells CMAN a new value of expected votes and instructs it to recalculate
       quorum based on this value.

       The recalculation takes into account the number of currently
       active nodes, so this option should not be used in an attempt to
       artificially lower the quorum value in advance of a planned shutdown of
       cluster nodes.  Instead, the 'cman_tool leave remove' command should be
       used(see the 'leave' subcommand above).

       Use this option if your cluster has lost quorum due to nodes failing and
       you need to get it running again in a hurry.

Version-Release number of selected component (if applicable):
cman-2.0.115-68.el5_6.1

How reproducible:
Everytime

Steps to Reproduce:
1. Open the man page for cman_tool.
  
Actual results:
The man page for cman_tool is to vague for the "expected" option.

Expected results:
The man page cman_tool should give end user more information about the 
"expected" option.

Additional info:
If bug is accepted then this should be cloned to RHEL6 as well since it has the same issue with a vague description of "expected" option.
Comment 2 Dean Jansa 2011-05-11 19:07:03 EDT
  expected
              Tells  CMAN  a  new  value of expected votes and instructs it to
              recalculate quorum based on this value.
              The recalculation takes into account  the  number  of  currently
              active nodes, so this option should not be used in an attempt to
              artificially lower the quorum value  in  advance  of  a  planned
              shutdown  of  cluster  nodes.   Instead,  the  ’cman_tool  leave
              remove’ command should  be  used  (see  the  ’leave’  subcommand
              above).
              Use  this  option  if  your cluster has lost quorum due to nodes
              failing and you need to get it running again in a hurry.


Verified in cman-2.0.115-82.el5
Comment 3 errata-xmlrpc 2011-07-21 03:25:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1001.html

Note You need to log in before you can comment on or make changes to this bug.