This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 688711 - Receiving periodic swarms of 'kernel:Uhhuh. NMI received for unknown reason 31|00|21 on CPU N.
Receiving periodic swarms of 'kernel:Uhhuh. NMI received for unknown reason 3...
Status: CLOSED DUPLICATE of bug 688547
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.1
x86_64 Linux
high Severity high
: rc
: 6.1
Assigned To: Don Zickus
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-17 15:24 EDT by Barry Marson
Modified: 2013-11-13 00:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-18 11:11:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
cpuinfo file from bigi system (5.21 KB, text/plain)
2011-03-17 15:24 EDT, Barry Marson
no flags Details

  None (edit)
Description Barry Marson 2011-03-17 15:24:02 EDT
Created attachment 486086 [details]
cpuinfo file from bigi system

Description of problem:
The bigi testbed which runs SPECsfs NFS worload is receiving messages of the form ...

Message from syslogd@bigi at Mar 16 17:17:21 ...
 kernel:Uhhuh. NMI received for unknown reason 31 on CPU 0.

Message from syslogd@bigi at Mar 16 17:17:21 ...
 kernel:Do you have a strange power saving mode enabled?

Message from syslogd@bigi at Mar 16 17:17:21 ...
 kernel:Dazed and confused, but trying to continue

Message from syslogd@bigi at Mar 16 17:17:21 ...
 kernel:Uhhuh. NMI received for unknown reason 00 on CPU 1.

Message from syslogd@bigi at Mar 16 17:17:21 ...
 kernel:Do you have a strange power saving mode enabled?

Message from syslogd@bigi at Mar 16 17:17:21 ...
 kernel:Dazed and confused, but trying to continue

...

in bursts with the 2.6.32-122 kernel.  Tests with the -118 kernel show no problem.  The cpuinfo for this server, an HP DL580g2 (Intel) has been attached.  I have tried disabling hyper threads at the BIOS but we still get errors.  Disabling nmi_watchdog in /proc/sys/kernel makes them go away.

I have talked to dzickus about this ...


Version-Release number of selected component (if applicable):
2.6.32-122

How reproducible:
everytime

Steps to Reproduce:
1. run specsfs on bigi testbed for sure
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Prarit Bhargava 2011-03-18 08:38:37 EDT
bmarson, we need more logs than what you have above.

P.
Comment 3 Don Zickus 2011-03-18 11:11:58 EDT
Barry,

I thought you were the first one to notice this yesterday, turns out you are already the third bz filed for it. :-)

I hate p4 boxes.

*** This bug has been marked as a duplicate of bug 688547 ***
Comment 4 higkoo 2013-11-13 00:28:18 EST
I had see
kernel:Uhhuh. NMI received for unknown reason 31 on CPU 0.
kernel:Uhhuh. NMI received for unknown reason 21 on CPU 0.
kernel:Do you have a strange power saving mode enabled?
kernel:Dazed and confused, but trying to continue

I had try :
add ‘nmi_watchdog=0 pcie_aspm=off nohpet’ to kernel param
change a older kernel

Result:
Use a older kernel 2.6.32-131.21.1 (default is 2.6.32-358.23.2)。

Note You need to log in before you can comment on or make changes to this bug.