Bug 68872 - sucky fonts in KDE startup
sucky fonts in KDE startup
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kdebase (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-15 11:50 EDT by James Manning
Modified: 2007-04-18 12:44 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-31 15:19:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
check the crappy font look for "Initializing peripherals" (170.72 KB, image/png)
2002-07-15 11:51 EDT, James Manning
no flags Details
fonts in CC and konq looking bad (175.76 KB, image/png)
2002-07-16 17:04 EDT, James Manning
no flags Details

  None (edit)
Description James Manning 2002-07-15 11:50:11 EDT
dunno if this is like bug 68476 with the monospace/fixed difference needing a
hack or what, but the startup fonts look pretty bad IMHO - sshot coming

bringing the cc/assign over from that bug just in case it's the same basic root
cause
Comment 1 James Manning 2002-07-15 11:51:42 EDT
Created attachment 65404 [details]
check the crappy font look for "Initializing peripherals"
Comment 2 Owen Taylor 2002-07-15 18:31:36 EDT
Seems unrelated. 

Somehow, the font being used here is a badly rendered bitmap; and
thus probably not going through Xft at all. 

One would have to investigate how that text is being drawn.


Comment 3 Aleksey Nogin 2002-07-16 11:43:42 EDT
I'll have to dbl-check, but if I am not mistaken, this looks much better in my
setup...
Comment 4 James Manning 2002-07-16 11:49:04 EDT
this is @ 1152x864 res, S3 Savage Pro4 card if that makes a diff - if it's
really bitmap it may just be crappy at certain res's, but 1152x864 seems like it
should be high enough not to suck :)
Comment 5 Owen Taylor 2002-07-16 15:47:17 EDT
It really shouldn't be a bitmap at all.
Comment 6 James Manning 2002-07-16 16:01:03 EDT
um, ok :)

So where do we go from here?

than?  Any luck on a cause?
Comment 7 Owen Taylor 2002-07-16 16:23:28 EDT
Looking at the code, there is nothing very special about this label:

    status_label->setText(text);
    QFont status_font = QFont(status_label->font());
    status_font.setBold(true);
    status_label->setFont(status_font);

Bold fonts seem to work OK in general for me in Qt/KDE.

Does it matter what you have set for your "General Font" in the
KDE control center?
Comment 8 James Manning 2002-07-16 17:03:58 EDT
actually - that's kind of interesting - the crappy-looking bold font appears to
be the same as the "window title" font (looks like bold helvetica 12).  I'll
sshot.  Notice how the bold looks bad in the konq window too
Comment 9 James Manning 2002-07-16 17:04:35 EDT
Created attachment 65584 [details]
fonts in CC and konq looking bad
Comment 10 James Manning 2002-07-16 17:09:11 EDT
interesting side note: in the KDE CC, the default fonts are "helvetica 12"
(mainly) which has helvetica lower-cased.  If you do a "Choose font", *all* the
fonts listed start with a capital letter, so you can't get "back" to "helvetica 12".
Comment 11 Owen Taylor 2002-07-16 17:42:25 EDT
Oh. turn on "Use antialising for fonts". Without doing that, things
are going to inevitably going to look sucky.

(I apologize if you aren't a fan of antialiasing; the problem is
that the way we used to do "non-antialiased text" and make it
look good was to use a few selected bitmaps that looked nice.
Unfortunately, this just doesn't work when you are trying to
provide a nice consistent interface to fonts to users and developers -
"you can use Helvetica, but only if you aren't
antialiasing, and only at sizes 12,14, and 18." is making things
really complex and hard to get right.)

We may eventually have embedded bitmaps in our default fonts so
they'll look good non-antialiased at the sizes where we have
bitmaps, and less good elsewhere.)

Getting the default KDE font settings right is a place we still
need to do a fair bit of work.
Comment 12 Ngo Than 2002-07-16 20:11:43 EDT
it's fixed now in kdebase-3.0.2-3. Antialiasing is default on.
start kpersonalizer and choose redhat style it should works fine.
Comment 13 Chris Ricker 2002-08-24 13:03:16 EDT
it's still sucky in null in kdm
Comment 14 Jay Turner 2002-08-29 21:51:32 EDT
Things look tons better with kdebase-3.0.3-7.
Comment 15 Chris Ricker 2002-08-31 10:42:17 EDT
Things are sorta better with kdebase-3.0.3-7

Here's what I see with that.

Install beta5, get sucky fonts (gotta love that technical jargon ;-) in kdm
up2date, get kdebase-3.0.3-7, still have sucky fonts in kdm
run kcontrol manually, force anti-aliasing on, then get non-sucky kdm fonts

Is there any reason anti-aliasing can't be turned on out of the box?
Comment 16 Ngo Than 2002-08-31 15:19:27 EDT
turn on AntiAliasing as default fixes this bug. 3.0.3-9 has this fixes
Comment 17 Jay Turner 2002-09-03 12:45:50 EDT
kdebase-3.0.3-10 has anti-alias fonts by default.

Note You need to log in before you can comment on or make changes to this bug.