Bug 688787 - (JBPAPP-6129) httpd.conf on Windows being looked up at wrong path.
httpd.conf on Windows being looked up at wrong path.
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Apache (Show other bugs)
JON 2.4.0
Unspecified Windows
medium Severity medium
: ---
: JON 3.1.2
Assigned To: Lukas Krejci
Mike Foley
https://issues.jboss.org/browse/JBEWS...
:
Depends On:
Blocks: jon30-sprint8
  Show dependency treegraph
 
Reported: 2011-03-17 21:56 EDT by Ondřej Žižka
Modified: 2013-09-11 07:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 07:02:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBEWS-101 Major Closed [Bug 688787] JON 2.4.1 + EWS 1.0.2-CR1 on Windows: httpd.conf being looked up at wrong path. 2013-01-25 09:57:07 EST

  None (edit)
Description Ondřej Žižka 2011-03-17 21:56:04 EDT
2011-03-17 21:36:37,520 INFO  [InventoryManager.discovery-1] (rhq.core.pc.inventory.AutoDiscoveryExecutor)- Process scan auto-detected new server resource: scan=[ProcessScan: query=[process|basename|match=(?i)httpd.exe,process|basename|match|parent=(?i)httpd.exe], name=[HttpdOnWindows]], discovered-process=[process: pid=[3080], name=[C:\Program Files\Red Hat\Enterprise Web Server\bin\httpd.exe], ppid=[4528]]
2011-03-17 21:36:37,523 WARN  [ResourceDiscoveryComponent.invoker.daemon-33] (rhq.plugins.apache.parser.ApacheConfigReader)- Apache configuration file C:\Program Files\Red Hat\Enterprise Web Server\Program Files\Red Hat\Enterprise Web Server\etc\httpd\conf\httpd.conf was not found.
2011-03-17 21:36:37,523 ERROR [ResourceDiscoveryComponent.invoker.daemon-33] (org.rhq.plugins.apache.ApacheServerDiscoveryComponent)- Discovery of Apache process [process: pid=[4528], name=[C:\Program Files\Red Hat\Enterprise Web Server\bin\httpd.exe], ppid=[620]] failed with an exception.
org.rhq.plugins.apache.parser.ApacheParserException: Apache configuration file C:\Program Files\Red Hat\Enterprise Web Server\Program Files\Red Hat\Enterprise Web Server\etc\httpd\conf\httpd.conf was not found.
	at org.rhq.plugins.apache.parser.ApacheConfigReader.searchFile(ApacheConfigReader.java:26)
	at org.rhq.plugins.apache.parser.ApacheConfigReader.buildTree(ApacheConfigReader.java:19)
	at org.rhq.plugins.apache.ApacheServerDiscoveryComponent.loadParser(ApacheServerDiscoveryComponent.java:423)
	at org.rhq.plugins.apache.ApacheServerDiscoveryComponent.discoverSingleProcess(ApacheServerDiscoveryComponent.java:164)
	at org.rhq.plugins.apache.ApacheServerDiscoveryComponent.discoverResources(ApacheServerDiscoveryComponent.java:89)
	at sun.reflect.GeneratedMethodAccessor36.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.rhq.core.pc.util.DiscoveryComponentProxyFactory$ComponentInvocationThread.call(DiscoveryComponentProxyFactory.java:279)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:662)g
Comment 1 Ondřej Žižka 2011-03-17 21:56:56 EDT
STR:

1) Install EWS as per installation instructions text file
2) Run Tomcat6, inventorize
3) See the agent.log
Comment 2 Lukas Krejci 2011-11-02 11:39:25 EDT
Could not reproduce this anymore. Works as expected (i.e. no warnings in the logs and apache inventoried successfully).

As a side note, I installed EWS according to the docs and ran through the installation procedure as noted here:

http://docs.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/1.0/html/Installation_Guide/sec-Configuring_the_Environment-Win.html

I also assume that the step 2 "run tomcat6, inventorize" should really say "run httpd, inventorize", because this is a apache related bug.
Comment 3 Sunil Kondkar 2012-12-12 09:58:35 EST
Verified on JON 3.1.2 ER4
Installed EWS according to installation instructions and started httpd.
apache is discovered and inventoried successfully without error in agent log.
Comment 4 JBoss JIRA Server 2013-01-25 03:08:30 EST
RH Bugzilla Integration <no-reply@redhat.com> updated the status of jira JBEWS-101 to Closed

Note You need to log in before you can comment on or make changes to this bug.