This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 688956 - kcm_touchpad: "Enable Tapping" doesn't work
kcm_touchpad: "Enable Tapping" doesn't work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kcm_touchpad (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
: FutureFeature
: 690507 871947 (view as bug list)
Depends On:
Blocks: F19Target-kde F20Target-kde
  Show dependency treegraph
 
Reported: 2011-03-18 12:25 EDT by Rex Dieter
Modified: 2014-08-08 14:35 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-08 14:35:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2011-03-18 12:25:36 EDT
kcm_touchpad's "Enable Tapping" option doesn't seem to work for me.  Worked swell on this same laptop (Dell Latitude D620) in f13, f14.
Comment 1 Kevin Kofler 2011-03-24 12:34:02 EDT
*** Bug 690507 has been marked as a duplicate of this bug. ***
Comment 2 Martin Klapetek 2011-03-31 18:05:09 EDT
Same for me on F14 x86_64 KDE on MacBook Pro, it was working after clean install from live cd, then I did full system update (from kde-testing repo) and after reboot it stopped working. Though things like two finger scrolling works.
Comment 3 Scott Williams 2011-04-06 00:43:54 EDT
I can confirm this in f14 with kcm_touchpad-0.3.1-6.fc14.x86_64.
Comment 4 Rex Dieter 2011-04-13 14:35:03 EDT
Just to document a workaround, run:
synclient TapButton1=1
Comment 5 Rex Dieter 2011-04-13 14:41:52 EDT
OK, silliness, now that we don't ship a default kcmtouchpadrc, seems that the defaults are even if "Enable Tapping" checkbox is enabled, the GUI action for "One finger", "Two Fingers", "Three Fingers" all map to "None", instead of ... something saner like "left button". :)
Comment 6 Kevin Kofler 2011-04-13 14:48:05 EDT
Oh, so THAT'S the silliness. I'll have a look at fixing this properly.

The default kcmtouchpadrc is not a good solution because it hardcodes some constants which aren't good for some hardware. We should use driver defaults where possible.
Comment 7 Rex Dieter 2011-11-04 17:53:09 EDT
Rebasing to f16, just noticed it still here. :(
Comment 8 Edney Matias 2012-04-17 20:09:22 EDT
Running Fedora 17 beta 1 and the bug stills here. :S

Do you need any info? Running a Dell Latitude here also.
Comment 9 Kevin Kofler 2012-11-01 19:01:08 EDT
*** Bug 871947 has been marked as a duplicate of this bug. ***
Comment 10 Orion Poplawski 2014-08-08 14:35:19 EDT
I can enable it.

Note You need to log in before you can comment on or make changes to this bug.