Bug 688958 - (CVE-2011-1148) CVE-2011-1148 php: use-after-free vulnerability in substr_replace()
CVE-2011-1148 php: use-after-free vulnerability in substr_replace()
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
David Kutálek
impact=moderate,public=20110313,repor...
: Security
Depends On: 740731 740732 740733 740734 768025 769756 831135
Blocks: 715030 750552
  Show dependency treegraph
 
Reported: 2011-03-18 12:30 EDT by Vincent Danen
Modified: 2016-03-04 07:31 EST (History)
5 users (show)

See Also:
Fixed In Version: php 5.3.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-19 17:21:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vincent Danen 2011-03-18 12:30:58 EDT
Common Vulnerabilities and Exposures assigned an identifier CVE-2011-1148 to
the following vulnerability:

Name: CVE-2011-1148
URL: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-1148
Assigned: 20110303
Reference: http://openwall.com/lists/oss-security/2011/03/13/2
Reference: http://openwall.com/lists/oss-security/2011/03/13/3
Reference: http://openwall.com/lists/oss-security/2011/03/13/9
Reference: http://bugs.php.net/bug.php?id=54238
Reference: http://www.securityfocus.com/bid/46843
Reference: http://xforce.iss.net/xforce/xfdb/66080

Use-after-free vulnerability in the substr_replace function in PHP
5.3.6 and earlier allows context-dependent attackers to cause a denial
of service (memory corruption) or possibly have unspecified other
impact by using the same variable for multiple arguments.
Comment 3 Vincent Danen 2011-08-18 12:15:24 EDT
This is corrected in upstream 5.3.7:
http://www.php.net/archive/2011.php#id2011-08-18-1
Comment 6 errata-xmlrpc 2011-11-02 18:24:25 EDT
This issue has been addressed in following products:

  Red Hat Enterprise Linux 5
  Red Hat Enterprise Linux 6

Via RHSA-2011:1423 https://rhn.redhat.com/errata/RHSA-2011-1423.html
Comment 8 Huzaifa S. Sidhpurwala 2012-01-16 23:08:06 EST
This issue did not affect the version of php shipped with Fedora 15 and Fedora 16.
Comment 9 Tomas Hoger 2012-01-17 03:34:17 EST
(In reply to comment #8)
> This issue did not affect the version of php shipped with Fedora 15 and Fedora
> 16.

It's probably less confusing to say that Fedora 15 and 16 are not affected by this issue as they ship fixed upstream version.  F-15, however, included php 5.3.6 at GA and as this issue was first fixed upstream in 5.3.7 (see comment #3), it probably was affected by this issue for some time.
Comment 10 Vincent Danen 2012-01-18 12:39:31 EST
Statement:

This issue did not affect the versions of php as shipped with Red Hat Enterprise Linux 4.
Comment 11 errata-xmlrpc 2012-01-18 13:44:43 EST
This issue has been addressed in following products:

  Red Hat Enterprise Linux 5

Via RHSA-2012:0033 https://rhn.redhat.com/errata/RHSA-2012-0033.html

Note You need to log in before you can comment on or make changes to this bug.