Bug 688959 - Remove hal dependency
Remove hal dependency
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lxsession (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-18 12:32 EDT by Nicola Soranzo
Modified: 2011-03-28 23:54 EDT (History)
1 user (show)

See Also:
Fixed In Version: lxsession-0.4.5-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-24 20:23:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicola Soranzo 2011-03-18 12:32:59 EDT
Description of problem:
According to this upstream bug report:

http://sourceforge.net/tracker/index.php?func=detail&aid=2987941&group_id=180858&atid=894872

lxsession doesn't require HAL anymore since version 0.4.5 .  Since HAL has been deprecated for 2 years, Fedora is trying to remove it from the distribution:

https://fedoraproject.org/wiki/Features/HalRemoval

I tried to remove the line:

Requires:       hal

from lxsession.spec and the package builds correctly.
I don't use LXDE, so I haven't tested it.

Version-Release number of selected component (if applicable):
lxsession-0.4.5-2.fc15
Comment 1 Fedora Update System 2011-03-24 20:16:46 EDT
lxsession-0.4.5-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/lxsession-0.4.5-3.fc15
Comment 2 Fedora Update System 2011-03-28 23:54:39 EDT
lxsession-0.4.5-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.